Go Down

Topic: El puerto COM esta en uso ¿como solucionarlo? (Read 4624 times) previous topic - next topic

ionhs

Apr 13, 2012, 12:42 pm Last Edit: Apr 13, 2012, 12:58 pm by ionhs Reason: 1
Hola hace unos días que me suele salir a veces un aviso que el puerto COM18 está ocupado por algún programa. No tengo nada abierto. Cierro el Arduino IDE, abro y a veces funciona otras no. Cuando funciona es por poco tiempo. Este problema me esta haciendo perder el tiempo.

Hay alguna manera de saber que es lo que está ocupando el puerto COM18 (he probado cambiando de puerto usb y con otro COM y acaba pasando lo mismo). Porque me da la otra es formatear el PC pero no me apetece mucho.

Puede ser algún problema con los servos trucados y que este mandando datos por el puerto serie. No debería pero...
La otra posibilidad es que los servos estén mal trucados y que generen cortos.  :smiley-roll:

ingestado

Tuve el mismo problema y mirando en foros lo solucioné.
Hay que utilizar una fuente de alimentación externa para los servos. Si no, los servos vuelven "loca" a la placa Arduino y esta abre el puerto serie (si estás utilizando Serial) y no lo vuelve a cerrar. Pasado un tiempo, Windows suele cerrar los puertos que no están en uso.
Conecta las tierras de arduino y la fuente de alimentación.
Espero que ayude!

Solo te pasa con esa placa? o con todas?

A mi me paso algo parecido con un arduino MEGA, le desactive el autoreset y conseguí volverla a re-programar. Por algún motivo al resetear la placa se bugeaba el puerto.
También podría haberlo solucionado creo yo volviendo a quemar el bootloader pero no caí en ese momento.

También ha habido casos por el foro que algún programa acede al puerto serie como algún programa del moden serie de móviles.

Haber si consigues solucionarlo y nos cuentas.

Un saludo!

eried

Si es posible prueba: http://arduino.cc/forum/index.php/topic,118440.0.html

Le he cambiado winavr, me encantaria lograr una versión que funcione mejor con este tipo de problemas.
My website: http://ried.cl

Omnimusha

un problema muy comun para mi. el problema parece ser que cuando desconectas, sacas el usb, no se cierra
la conexión en algunas ocaciones, entonces cuando vuelves  a conectar el arduino dice " El puerto COM xxx esta en uso".
Solucion..... cargo el strech sin conectar el arduino, para que retifique , se de cuenta con no esta conectado y cambie su estado de activo , pasivo--- aveces funciona.


...solucion 100% . reinicio la pc.  :D

Go Up