Go Down

Topic: Error message: avrdude: stk500_getsync(): not in sync: resp=0x00 (Read 4 times) previous topic - next topic

Asger81

Jun 24, 2012, 09:14 am Last Edit: Jun 24, 2012, 03:53 pm by Asger81 Reason: 1
Hi guys

First of all, Im a noob, so bare with me.

I Just recieved my Arduino yesterday, and have spent all day trying to find a solution for the "avrdude: stk500_getsync(): not in sync: resp=0x00" error message.   :~
I know there is a lot of subjects in the forum about this already, but none of the solutions have seemed to work for me.

I run a Windows 64-bit computer and the arduino is a Duemilanove ATmega328.

I followed the tutorial on this site on how to get started. When I plugged in my Arduino board, the drivers where successfully installed automatically.
When I check my devices. It says, that it is working proberly and is on COM3.

I made sure to choose the right board and com port in the software.
I also tried resetting the board manually, before/ and during upload (even though what I read suggests the duemilanove has an automatic re-set function yes?)

But when I press upload the following happens (been trying with the blink example sketch):

the RX blinks 3 times, then a pause for approx 10 sec. then the red L13 will be blinking continously.

The bar in the bottom writes:

Uploading...
Binary sketch size: 1.084 bytes (of a 30.720 byte maximum

and then (with verbose output enabled):

Done uploading
Binary sketch size: 1.084 bytes (of a 30.720 byte maximum)
C:\Users\Asger\Documents\Arduino\arduino-1.0.1\hardware/tools/avr/bin/avrdude -CC:\Users\Asger\Documents\Arduino\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P\\.\COM3 -b57600 -D -Uflash:w:C:\Users\Asger\AppData\Local\Temp\build857580504558195651.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Users\Asger\Documents\Arduino\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.


I also did the loop back test. It worked.
Could it be something with the BAUD rate? (I already tried different options with no success).

And what should the "Tools -> programmer -> " be set to? It was set by default to AVRISP mkII (But what is it?)

Any help will be greatly appreciated! Thanks   :)

Louis Davis

Where did you get the Duemilanove? A link to the one you ordered would help.

It's possible the Duemilanove you have, may have a different bootloader installed. Try setting the board type to UNO to see if it may have the UNO's bootloader installed.

Asger81

#2
Jun 24, 2012, 05:17 pm Last Edit: Jun 24, 2012, 06:33 pm by Asger81 Reason: 1
Hi Louis

I bought it as a start kit including some sensors etc. from dealextreme.com ( http://www.dealextreme.com/p/duemilanove-2009-atmega-328p-basic-kits-for-arduino-starters-122866?item=59 )

(Ive been thinking if it is a fake?)

I have tried changing the setting to most of the boards, but with no success  :~

Louis Davis

That board does not look like an official Arduino board.

This is what it should look like if it was an official Arduino board : http://arduino.cc/en/Main/ArduinoBoardDuemilanove

Asger81

Ok, I have ordered a new Arduino Uno from ebay.co.uk. Hope I have better luck with that  -  but still odd that I can get it to work.
Thanks for the help anyway!

Go Up