Pages: [1]   Go Down
Author Topic: Use Arduino as ISP to reflash Atmega8 as USB-Serial  (Read 390 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

After some use, my Arduino UNO clone has started throwing errors when plugged into windows. I am getting a device malfunction error.

I have Googled the topic for days, and have not been able to find instructions on how to use another (Working) arduino that I have (Mega2560) as ISP to reflash the Atmega8 for USB to serial conversion on the UNO. I have removed the Atmega328-P from the IC socket, and plugged in the board to receive the same error. Mac, Linux or Windows on different machines are also giving me the error, so it is not just the USB port on my computer. I can use the Mega fine.

I have tried reinstallation of drivers though the issue seems that the Atmega8 is not working on the USB side.
It is likely that metal objects came into contact with pins of the Atmega8. (I know its tiny, but when cutting wires...)

Before checking the board, or buying a proper ISP i would like to know if I am able to use a Mega2560 as ISP to reflash the Atmega8 USB - serial microcontroller on the arduino UNO with the default firmware from arduino repo on GIT (Arduino-uno-usbserial (I think))

Thanks, links to some kind of instruction or some advise on how to achieve this would be great!

Regards,
Chris
Logged

Pages: [1]   Go Up
Jump to: