Pages: [1]   Go Down
Author Topic: Severe IDE bug with 0017 and 0018 on Ubuntu  (Read 1182 times)
0 Members and 1 Guest are viewing this topic.
Dallas
Offline Offline
Sr. Member
****
Karma: 3
Posts: 337
nephew as a kittens
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

In Ubuntu 9.04 I had a intermittant bug where the arduino window would stop accepting all keyboard input. Mouse buttons still worked, so I would have to save using the save button, then restart Arduino. This happened nearly every time I alt-tabbed.

Since upgrading to 9.10 now this happens any time I move, resize, or maximize the arduino window. It stops accepting all keyboard input. It is not hung though and still accepts mouse input. I tried installing 0018 and it's no different.

This is a crippling bug. Is there anything I can do?
« Last Edit: February 18, 2010, 11:07:57 pm by BetterSense » Logged

Dallas
Offline Offline
Sr. Member
****
Karma: 3
Posts: 337
nephew as a kittens
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I installed KDE and tried from within KDE an behavior is the same.
Logged

Wuppertal/Germany
Offline Offline
God Member
*****
Karma: 1
Posts: 895
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
which java runtime are you using? There is nothimg really in the arduino-code that could expalin this behaviour. So I guess the JavaRuntime is causing the trouble.
Could you post the output of this console-command
Code:
update-alternatives --display java

Eberhard
Logged

Lancashire, UK
Offline Offline
Edison Member
*
Karma: 9
Posts: 1991
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I use Ubuntu (8.10, 9.04 and 9.10) with Arduino 0017 and 0018, never had a keyboard issue at all.  I'm with Wayoda, all the issues I have had have been with Java.  In synaptic package manager, remove all the Java runtime stuff and install just the latest Sun JRE and its dependancies / plugins.  The default open source stuff often conflicts with it in my experience.
Logged


Dallas
Offline Offline
Sr. Member
****
Karma: 3
Posts: 337
nephew as a kittens
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Code:
chaz@singularity:~$ update-alternatives --display java
java - auto mode
 link currently points to /usr/lib/jvm/java-6-sun/jre/bin/java
/usr/lib/jvm/java-6-sun/jre/bin/java - priority 63
 slave java.1.gz: /usr/lib/jvm/java-6-sun/jre/man/man1/java.1.gz
Current `best' version is /usr/lib/jvm/java-6-sun/jre/bin/java.
chaz@singularity:~$

Thanks for the info. If it's java, there's no point in my trying other solutions like trying another window manager. Arduino is the only thing I've had trouble with except pidgin. But it might be java since arduino is java. I will try the reinstalling thing. I just upgraded to 9.10 and installed sun-java-bin to get arduino working. I can't imagine it's not the most current.
Logged

Dallas
Offline Offline
Sr. Member
****
Karma: 3
Posts: 337
nephew as a kittens
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried going into synaptic and reinstalling all the java stuff and it still does it. Any time I move the window or switch to a different window it stops accepting all keyboard info until I restart it. I have tried coding with a text editor and trying to compile the code without the Arduino program but the makefile was completely hopeless and I never got it to work. I literally can't finish the projects I'm working on at this rate.
Logged

Dallas
Offline Offline
Sr. Member
****
Karma: 3
Posts: 337
nephew as a kittens
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

In case anyone else has this problem, it was caused by scim. By killing scim the problem went away. Of course I haven't figured out how to type Japanese without scim, but at least I can type English now!
Logged

Wuppertal/Germany
Offline Offline
God Member
*****
Karma: 1
Posts: 895
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
just in case I see that problem again:
  • You are running a japanese version of Ubuntu and scim does not work with the Arduino-IDE.
  • You have to kill/disable scim and then you are able to code in english

When I downloaded the JRE from Sun I think there has always been a special japanese version of the JRE.   Is there one on Ubuntu?

I can't read this maybe it provides a hint for you?
http://java.sun.com/javase/ja/6/download.html

Eberhard
Logged

Dallas
Offline Offline
Sr. Member
****
Karma: 3
Posts: 337
nephew as a kittens
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am not running a Japanese version of Ubuntu. I installed the normal english version, but I added Japanese language support via the gui tools. I never actually got it to work because they switched from scim to ibus for Karmic and it did not work for me out-of-the-box. In the process of trying to get japanese input to work, I installed scim. It is scim that was causing the bug. I could run "pkill scim" and the problem would instantly go away. I have since given up on Japanese input on that machine, since I don't usually need it.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

I had the same problem that keyboard seems frozen.

I  think the issue is more related to "Processing". I installed "Processing" and did some coding there. I found the same keyboard frozen issue. That's why it should be "Processing", and Arduino has inherited the same bug.

I also tried to use Sun Java instead, but the problem didn't go away.

I use another trick by opening an extra "dummy" sketch, by clicking File>New. This sketch is just a blank sketch and you need not code anything in it. So you have 2 open sketches on your windows desktop.

Something like this:
http://i913.photobucket.com/albums/ac331/bigtrumpet/screenshot.jpg

When you find your keyboard not responding, you can use your mouse to jump to "dummy" sketch first. And if you find your keyboard is alive again, you jump back ( using your mouse) to your working sketch

In my case, I can still leave scim running.

Cheers

Joseph
Logged

Pages: [1]   Go Up
Jump to: