Go Down

Topic: NoClassDefFoundError: processing/app/Base (Debian) (Read 1 time) previous topic - next topic

Thempra

I try to install arduino IDE in my debian SID with this how to:

http://www.arduino.cc/playground/Linux/Debian

then I install the package  sun-java5-jre sun-java6-jre librxtx-java

but when I run /usr/lib/arduino/arduino , I get an error:

Exception in thread "main" java.lang.NoClassDefFoundError: processing/app/Base


Where is the problem????


Thempra

I try again with the copy in the svn ( arduino-0009 ) and I get the same error:

Exception in thread "main" java.lang.NoClassDefFoundError: processing/app/Base

mellis

I'm not sure quite how the debian package is set up, but it sounds like you need to add a directory to your CLASSPATH environment variable.  There should be a pde.jar somewhere from the Arduino package, and it or the directory it's in needs to be in your classpath.  You can try something like in a terminal:

export CLASSPATH=/usr/lib/arduino:$CLASSPATH

And then run Arduino.

Thempra

Thank you for the idea !!

I run it, I edit the file arduino an put at the end in the line CLASSPATH:

Code: [Select]

CLASSPATH=java/lib/rt.jar:lib:lib/build:lib/pde.jar:lib/core.jar:lib/antlr.jar:lib/oro.jar:lib/registry.jar:lib/mrj.jar:lib/RXTXcomm.jar:/usr/lib/arduino


Only work if I run it since the path /usr/lib/arduino, but .... RUN !!! ;)

af3556

You will see this problem if you start arduino from outside of its "home".

e.g. if you don't want to fiddle with CLASSPATH, this should work:

Code: [Select]
$ cd /path/to/arduino-008/ && ./arduino

Rgds,
Ben


Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy