Go Down

Topic: problem uploading to Arduino mini pro (Read 25922 times) previous topic - next topic


Jun 04, 2009, 10:17 pm Last Edit: Jun 04, 2009, 11:54 pm by mbryson Reason: 1

I am stuck and cant upload to my arduino mini pro 5v 16Mhz.
I am using the USB/TTL from Robotshop that is working fine with my Arduino mini.

I have tried this :
My IDE is set at duemilanove 328 like Sparkfun is recommending and my com port is selected.

Pushing the reset button just before I upload. No result. Only one led is flashing dimmly for 3 times. no result

Modifying the IDE preference file and releasing reset after specific text appears : no text is appearing in the DOS window. no result

Using my Duemilanove and removing the Atmel328 and using it as a USB adapter like shown in the Arduino Mini guide. no result

My Arduino mini pro is doing a blink routine that last about 2 second and goes from slow to very fast. From my readings here this tells me that it is the factory sketch that is present on Arduino's when they get out of the box.
A red led is also on.

I have joined a film of it during the upload process. My next option will be to buy a Specific adapter for the Arduino Mini Pro from Sparkfun but I am wondering if I still can do something with what I have in hand ?


Thank you


Did you start it with "run.bat" ?

Linking a _private_ video on youtube doesn't help much.


Jun 04, 2009, 10:50 pm Last Edit: Jun 04, 2009, 11:02 pm by mbryson Reason: 1
LOL !!! its public now thanks for the heads up.

Yes I did start the Arduino with the bat file but nothing happened except 3 little blinks that you can see on the video.

I did soldered connectors to the board so it fits on the breadboard maybe I fried something. I did check my connection and the TX and RX line are good from one side to the other. I don't know if they are good up to the microchip, that would be my next step maybe something is wrong.I will try to find the chip layout and check tx and rx up to it...


Jun 04, 2009, 10:58 pm Last Edit: Jun 04, 2009, 11:08 pm by madworm Reason: 1
Strange, I don't see the RX/TX LEDs on your USB adapter blink.

Why ?

Do they blink at all (with the breadboard circuit disconnected from it) ?

I'm just blind...

So you just wired RX/TX to the board, no reset line ?

Seems like this usb adapter doesn't have the DTR line available as a pin...

Still I wonder why you didn't see any output in the DOS (ugh) window. What exactly did you change in preferences.txt and was it in /arduino-0015/lib/ ?


Jun 04, 2009, 11:12 pm Last Edit: Jun 04, 2009, 11:51 pm by mbryson Reason: 1
Is the reset on the board need to have a line to 5v too ?

I did try to do a manual reset with a wire like for the mini ( it worked on the mini not on the pro mini )

And I did change this text and there is output text when using my duemilanove :


Im starting to think that the arduino may have a problem... :'(


Jun 05, 2009, 12:07 am Last Edit: Jun 05, 2009, 12:12 am by madworm Reason: 1
Hm. The text messages should show up anyway.

But the pro mini needs to be reseted to activate the bootloader.

It seems you have an up to date version of the usb adapter. You need to connect its DTR pin to a special pin on the arduino mini pro. It seems the label on the board is wrong (at least on this image here):

Make a connection from the the pin in the bottom left corner, it is connected with a small capacitor to the reset line. It is the pin right above the label GRN.

Connect it to the DTR pin on your MINI USB board.

This should enable auto reset and uploads. Also make sure that RX/TX are not reversed.


I think I have exactly the same issue as you. I started by posting on the SF forums:
(Sorry I can't post real links yet)

So I am interested in what is going on here.
Mine blinks like yours, so I'm guessing that it is functioning correctly, and I am assuming that it was preloaded with the sk bootloader.

I do see the blinking stop as soon as the serial starts, so I think it is safe to assume that the DTR - Reset function is working.

I don't know, but I think we have the same problem.



Link to my post on the SF forums.

I think there are only a few possibilities:
1. Bad hardware? (Seems unlikely, its brand new for me)
2. Missing/misconfigured bootloader (SF dropped the ball?)
3. Misconfigured software (Possibly, I've tried it on two separate platforms and neither work)



Yes, it could be the upload speed setting. I think I've read about some cases.

Have a look at boards.txt and just try changing the speed for your mini pro:


The upload.speed used to be 19200, but was changed to 57600, maybe the bootloader on your chip still expects 19200.

If that should fix it, just create a new section for it in thte boards.txt to make it permanent.


Didn't seem to make a difference. (The baud rate change)

However, if Addict says that this flashing sequence is indicative of it coming from the factory (does the factory put a bootloader on it?), then maybe SF did not put a bootloader on it in the first place and it will never program like this.

The next thing I guess it building a ISP programmer?



Well I guess factory here doesn't mean atmel, but the manufacturer of the arduino. All chips I got from the FACTORY didn't have anything flashed and were completely silent until I flashed some code into them.

Yes, if you're using these boards anyway, an ISP won't hurt at all ;-)


I contacted Robot shop support and they suggested to buy the SFE FTDI USB to Serial Basic Breakout Board (5V).
And like MadWorm suggested I tried to connect DTR to GRN and CTS to BLK without positive result.

Now I am waiting for my part to be shipped. In the mean time I am looking into ISP programming too.

Thanks for your help and I will post any progress on the subject for everyone to enjoy.


Ok I just fixed my issue, and hopefully someone else's.

My arduino's (or possibly my solder job on the header?) RXI pin on the 6pin header side was not connected to the same pin as the RXI on the other side of the board. It seems that there was no connectivity to that pin to anything else on the board.

I solved my problem by jumping my dead RXI pin (on the 6pin side) to the other RXI in to achieve full connectivity.



I'm having the same problem with a 5V Pro Mini from Gravitech with a FTDI usb basic breakout board. I've tried every possible combination of RX/TX/DTR/CTS pin connections, and tried pressing reset at a zillion different times while watching the code compile/upload. i've also tried different board selections in the processing ide (started with run.bat).

no luck: whenever i turn on the pro mini or release the reset button the green LED gives a sequence of flashes that starts slow and gets faster and faster. the bootloader seems to be ok because i get a single green flash after every reset before it goes into the sequence.

what does the sequence mean? frustrating...


Hi all,

I had the same problem with my Arduino Mini Pro 8MHz/3.3v and found my/the answer.

The key is the bootloader that is on the Mini Pro:
If the default pattern of the led is (_ = off, * = on) :
__**__**__**__**__** (simple slow pace blinking) ... you must choose in the Arduino software "Board = Arduino Mini Pro" (my first Mini Pro was like that and working)

**** BUT ****

if the pattern is ____*____*___*__*_***** (like a drum rolling faster) you must choose "Board = Arduino Duemillanove w/ ATMega 328" ! And it started working just fine !

It took me a few hours to desperately try that, and it worked just fine   :) I think the key is that the "older" generation came with a old bootloader with a specific signature, but the new ones come with another signature that match the Duemillanove 328.

Hope this helps. At least it saved me from throwing my 3 Mini Pro to the bin! And no need for any kind of rewiring the FTDI connector, the Sparfun 3.3v works just fine it you plug it the right way (not upside down).


Go Up