Pages: [1]   Go Down
Author Topic: Problem uploading to Pro Mini via FTDI Basic USB  (Read 1990 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It seems like this is a pretty common problem. I have trawled the boards and tried lots of things out. Brand new Pro Mini 5v 16Mhz. New FTDI Basic too. Have tried with tools/board select = Pro Mini and several others with same result each time. Have same 57600 set in code and for USB properties. Also have 'Set RTS on close' selected in properties for the USB port as per Arduino guidance notes for Pro Mini.

Have tried on 2 Macs and PC running Parallels and get same result every time. Green on board led (and led connected to out 13) flashes on initial connection and at start of upload. Pushing reset button also flashes LED. I have previously successfully connected to Mega Pro, so I think drivers are OK.

Any advice or ideas would be appreciated. By the way, I am very much a newbie, so be gentle with me please.

Verbose output is below:


Binary sketch size: 1010 bytes (of a 30720 byte maximum)
C:\Users\Administrator\Documents\arduino-0021[1]\arduino-0021\hardware/tools/avr/bin/avrdude -CC:\Users\Administrator\Documents\arduino-0021[1]\arduino-0021\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM4 -b57600 -D -Uflash:w:C:\Users\ADMINI~1\AppData\Local\Temp\build2720414113592612904.tmp\sketch_dec21c.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
         Copyright (c) 2000-2005 Brian Dean,

         System wide configuration file is "C:\Users\Administrator\Documents\arduino-0021[1]\arduino-0021\hardware/tools/avr/etc/avrdude.conf"

         Using Port            : \\.\COM4
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 57600
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, sorry, I have no answer for you, but I just have the same problem, I also tried to program the Arduino Uno using an  USB to Uart bridge (CP2102) http://www.silabs.com/Support%20Documents/TechnicalDocs/cp2102.pdf and connecting it to the tx and rx pins, but I can't program it anyway... Anyone knows the solution?
Logged

Global Moderator
Boston area, metrowest
Offline Offline
Brattain Member
*****
Karma: 545
Posts: 27352
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You probably checked this, but you are selecting the correct COM port also?
I have a duemeilanove and several prominis, I switch back & forth lot. Duemilanove uses COM3, Promini uses COM7, I almost always forget to check and get the same error with the first programming attempt after changing from using one arduino type to the other.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yep I have the right com port. It is talking to it too. The green reset LED flashes twice when I try to upload.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Looks like it was a bad Pro Mini. A second board arrived in the mail today. I connected it up and straight away it worked fine. I recommend anyone having this problem tries this before wasting loads of time trying to work out what they have done wrong!
Logged

Global Moderator
Boston area, metrowest
Offline Offline
Brattain Member
*****
Karma: 545
Posts: 27352
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

That's a bit of a bummer! I have one damaged, had a loose wire in a box that shorted something  and took it out. Was looking for a replacement chip, haven't gotten there yet.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for your replies, i finally figure out what was my problem, I think that my Arduino mini (bought from china  :-/ )has been flashed without or  with a wrong bootloader. I used my Arduino uno as ISP following this guide:
http://arduino.cc/en/Tutorial/ArduinoISP
and then programmed tha Arduino using the same connections as described here:
http://www.arduino.cc/en/Guide/ArduinoMini
Logged

Pages: [1]   Go Up
Jump to: