Go Down

Topic: arduino0010 sur linux (Read 852 times) previous topic - next topic

akatronic

Malgré tous mes efforts, je ne parviens pas à lancer arduino (ou plutôt arduino se lance quelquefois sans savoir pourquoi)
La console renvoie une erreur: Exception in thread "main" java.lang.NoClassDefFoundError: processing/app/Base
Merci de votre aide

(Mon installation est normalement complète. Je n'ai pas brltty et les librairies avr-gcc et consorts ont été installées.)

nrolland

#1
Jan 18, 2008, 01:44 pm Last Edit: Jan 18, 2008, 01:45 pm by nrolland Reason: 1
Peux tu faire une sortie des variables d'environnement
As tu lu ca http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1183303612

Nicolas

akatronic

Quote
Peux tu faire une sortie des variables d'environnement

Code: [Select]

jerome@studio:~$ printenv
SSH_AGENT_PID=8362
SHELL=/bin/bash
DESKTOP_STARTUP_ID=
TERM=xterm
WINDOWID=27263051
USER=jerome
LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.flac=01;35:*.mp3=01;35:*.mpc=01;35:*.ogg=01;35:*.wav=01;35:
SSH_AUTH_SOCK=/tmp/ssh-oPuigi8329/agent.8329
GNOME_KEYRING_SOCKET=/tmp/keyring-Owki13/socket
SESSION_MANAGER=local/studio:/tmp/.ICE-unix/8373
USERNAME=jerome
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
DESKTOP_SESSION=xfce4
GDM_XSERVER_LOCATION=local
PWD=/home/jerome
LANG=fr_FR.UTF-8
GDMSESSION=xfce4
HISTCONTROL=ignoreboth
SHLVL=1
HOME=/home/jerome
LOGNAME=jerome
XDG_DATA_DIRS=etc/xdg/xubuntu:/usr/local/share/:/usr/share/:/usr/share/gdm/:/usr/share
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-YOODPUKzkf,guid=4b2e47ac7e39256514bf19004791b437
LESSOPEN=| /usr/bin/lesspipe %s
WINDOWPATH=7:7
DISPLAY=:0.0
LESSCLOSE=/usr/bin/lesspipe %s %s
COLORTERM=Terminal
XAUTHORITY=/home/jerome/.Xauthority
_=/usr/bin/printenv


Quote
As tu lu ca http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1183303612

J'avais lu mais étant un plutot nul avec java, j'avais un peu zappé.
Maintenant, je ne comprends pas le CLASSPATH.
S'agit-il d'une variable spécifique à java?

Bizarrement la commande
Code: [Select]
cd /opt/arduino-0010/ && ./arduino
lance arduino. Je peux même envoyer un sketch à ma carte  :)

Merci

nrolland

Ben c'est gagné alors  :)

Electroniquement votre

Nicolas

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy