Go Down

Topic: Problème avec le branchement d'un photo transistor (Read 1 time) previous topic - next topic

XpBot

Bonjour,

j'ai une carte arduino duemilanove et je viens d'acheter une LED IR et un photo transistor.

Le problème c'est que je n'arrive pas à faire fonctionner tous ce beau monde.

Je mets la LED sur le pin 13 dans le bon sens dans il émet (en théorie vu que l'on ne voit rien :-/). Ensuite je mets mon photo transistor sur une plaque d'essai.
je le relis comme cela. 5V=> résistance 10K=> patte extérieur. La patte du milieu n'est connecté à rien. Puis la dernière patte va à la masse.
De plus je ne sais pas quel est le sens du photo transistor. C'est un pavé avec sur un coté une collerette.
Après si je veux récupérer mon information sur le pin 3, je me branche où sur le photo transistor? j'ai essayé toutes les positions mais je n'ai rien. La LED est en face ou déconnecté, je n'obtiens aucune différence. Donc je suis un peu perdu.

Merci

fdufnews

Déjà, pour voir si la LED est bien allumée tu peux essayer de la regarder avec une webcam, la caméra d'un téléphone portable. Si c'est du proche infrarouge tu devrais voir une lueur.

En ce qui concerne ton phototransistor, le mieux serait de nous donner la référence de celui-ci pour que l'on puisse t'aider.

faipassa

#2
Dec 29, 2009, 08:37 pm Last Edit: Dec 29, 2009, 08:37 pm by faipassa Reason: 1
Quote

Déjà, pour voir si la LED est bien allumée tu peux essayer de la regarder avec une webcam, la caméra d'un téléphone portable. Si c'est du proche infrarouge tu devrais voir une lueur.


Perso, pour débugger, je remplace tout simplement mes diodes IR par des LED basiques rouge par exemple, dont les caractéristiques en V et A sont proches des versions IR. Si les LED clignotent, c'est que les infos passent  ;)

Dis nous en plus à propos de ton photo-transistor.

a+
Olivier

XpBot

Merci pour vos réponses.

Le problème c'est que je l'ai acheté dans une boutique à l'unité donc il n'y pas de référence  :-/

Go Up