Pages: [1]   Go Down
Author Topic: Arduino et Relais  (Read 604 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour
Je suis nouveau sur le Forum, J'ais une question.
J'ais monté une minuterie 16 relais et je n'arrive pas a activé les 16 relais en même temps.
Il faut envoyé 8 bits a la fois , donc je shifte (shiftOut) 2 fois pour 16 Bits.
Juste que la sa vas , Mais 16 relais activé en même temps sa prend 255 octels et la les 16 relais se déactive.
Si j'envoie 254 octels 15 relais son activé, mais d'est que je passe 254 tout se déactive.
Pourquoi ?.
Merci
Logged

Massongex, Suisse
Offline Offline
Full Member
***
Karma: 2
Posts: 169
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,
J'aimerais assez t'aider, mais je suis désolé je n'arrive pas à comprendre ta question. S'il te plait, essayes de structurer ta question, de faire un minimum attention à ton orthographe (ça aide à lire), et éventuellement de poster un exemple.
Je ne veux pas te faire la leçon, mais si tu veux que les gens fassent un effort pour te répondre, il te faut aussi en fournir un quand tu poses les questions.  smiley-wink
Churchill
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 76
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

tu utilise quelle sorte de variable pour stocker des bits ? ( un int, long ...)

je pense que tu n'utilise pas le bon type et donc tu arrive a la limite

tu dois utiliser un unsigned int je pense !
Logged

France
Offline Offline
Faraday Member
**
Karma: 23
Posts: 3025
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Un morceau de schéma aiderait à la compréhension de ton problème.
Logged

Pages: [1]   Go Up
Jump to: