Go Down

Topic: alimentation secteur + USB (Read 3823 times) previous topic - next topic

alexandra

Bonjour à tous,

Je réalise en ce moment mon premier projet avec Arduino et j'aurai besoin de quelques éclaircissements.

Voilà, mon circuit est branché sur 3 pins numériques et relié au 5V. Son état ON/OFF dépend de données récupérées en temps réel par le port série. J'ai donc besoin que mon arduino soit connecté par USB à mon mac.

Le montage fonctionne bien mais je souhaiterais quand même l'alimenter avec plus de courant: du 9 ou 12V par alimentation secteur.

Comment procède-t-on dans ce cas?

Merci.


fdufnews

Quote
Voilà, mon circuit est branché sur 3 pins numériques et relié au 5V.
Quel circuit, un circuit externe ou ton arduino?
Sur quel 5V, celui de l'arduino?

Quote
Je souhaiterais quand même l'alimenter avec plus de courant: du 9 ou 12V par alimentation secteur.
Comment procède-t-on dans ce cas?

Les cartes arduino (quelle carte utilises-tu?) on généralement une prise d'alimentation externe. Il suffit de raccorder ton alimentation externe sur cette prise. Suivant le type de carte il peut être nécessaire de déplacer un strap ou interrupteur pour indiquer si l'arduino est alimenté par l'USB ou une alimentation externe.

alexandra

Voilà quelques précisions:

- j'utilise le duemilanove

- mon circuit consiste en plusieurs fils de nichrome reliés chacun à une pin num et au 5V Power de l'arduino.

Peux tu m'expliquer comment faire avec mon modèle arduino pour lui indiquer une alimentation externe plutôt que l'USB?

Merci

B@tto

Nichrome ? Tu fais un four avec une arduino ???
Blog électronique : http://battomicro.wordpress.com/
Photographie : www.interactive-celebration.fr

ekaki

C'est peut-être pour une application en milieu marin ou en géologie; j'en connais qui font leurs montages avec ce type de conducteur sur leur sismographes -.^

alexandra

Ni four ni appareil à vocation sismique... :)

En fait, mon projet est très simple, mais requiert du 9V.

Le problème est que quand j'alimente mon circuit avec du 9V (pile) + USB, celui-ci s'alimente en continu (toujours ON) et non pas en fonction des données reçues sur le port série.

En plus, j'aimerais remplacer l'alimentation batterie par le secteur car j'ai peur qu'une pile ne tienne pas le coup très longtemps....

J'espère que vous avez une solution pas trop compliquée pour moi car je n'ai pas beaucoup de connaissances en électronique.

Merci pour le coup de main et n'hésitez pas à me demander des précisions.

ekaki

#6
Jun 08, 2010, 07:16 pm Last Edit: Jun 08, 2010, 11:43 pm by ekaki Reason: 1
Quote
Le problème est que quand j'alimente mon circuit avec du 9V (pile) + USB, celui-ci s'alimente en continu (toujours ON) et non pas en fonction des données reçues sur le port série.

C'est normal il me semble que cela reste alimenté, sinon L'Arduino ne peut plus recevoir les données venant du RS232 ?..

Ce n'est pas un problème d'interférence entre le port RS232 qui est connecté à l'ordi' et ton circuit ? C'est à dire qu'à chaque fois que quelque chose est envoyé à l'Arduino cela créer des "coupures" dans ton circuit ?..
Le problème est connu lorsqu'on utilise le port RS232 pour piloter un écran LCD et qu'on fait les mises à jour depuis d'ordi' : Cela affiche des caractères "exotiques" sur le LCD...

alexandra

Huumm, pas évident...

Voici un schéma, qui j'espère, éclaircira un peu les choses.

Les fils de nichrome sont tous reliés au 5V. Est-il possible de les alimenter par une alim externe tout en gardant l'usb qui "dit" quand envoyer le courant?



Merci pour vos posts  :)

ekaki

#8
Jun 09, 2010, 12:08 am Last Edit: Jun 09, 2010, 12:15 am by ekaki Reason: 1
Ha, on y voit un peu plus clair ^.^
Bien vu le schéma -.^

Ok, bon, tu n'utilises pas le tx/rx de l'Arduino donc cela élimine le problème dont je te parlais.

Par contre, il y a quelque chose que je trouve étrange; tu utilises le 5V fourni par l'Arduino pour quelque chose, OK, et tu utilises 3 voies numériques pour commander "d'autres choses".
Mais.. Tu ne raccordes rien à la masse ? Tu travailles en inversé (mise à la masse des voies numériques pour créer une différence de potentiel avec le 5V de l'Arduino) ?

Enfin, quoi qu'il en soit, cela ne change pas grand chose vis-à-vis de ta question initiale..
Si cela pose problème, une solution serait d'utiliser un câble USB dépourvu de sa partie énergétique afin d'être certain que l'Arduino soit alimenté par la prise dédiée à cet usage (ou par l'entrée Vin).
Mais "normalement", L'Arduino privilégie automatiquement l'alimentation provenant de la prise dédiée (ou de Vin) si présente en même temps qu'une source énergétique USB.. Donc il n'y a rien à faire de spécial -.^

alexandra

Ok, on commence à se comprendre  ;D

Donc, je n'ai rien à faire de spécial si je souhaite avoir une alim externe et de l'usb, si ce n'est connecter mes fils non plus au 5V mais la broche Vin...C'est bien ca ?

Sinon
Quote
Par contre, il y a quelque chose que je trouve étrange; tu utilises le 5V fourni par l'Arduino pour quelque chose, OK, et tu utilises 3 voies numériques pour commander "d'autres choses".
Mais.. Tu ne raccordes rien à la masse ? Tu travailles en inversé (mise à la masse des voies numériques pour créer une différence de potentiel avec le 5V de l'Arduino) ?

C'est plus flou...

Mon problème, est qu'actuellement, les fils de nichrome ne reçoivent que 40 mA (limite des pins numériques si j'ai bien compris), ce qui est trop juste.

Ce que j'aimerai, c'est savoir comment réaliser un montage pour que les fils de nichrome reçoivent le maximum de courant...peut-être-faut-il revoir le schéma pour plus d'efficacité (notamment vers la masse?)?

Qu'en penses-tu ?

B@tto

Si tu veux plus que 40 mA il va falloir utiliser des transistors ou des relais ou des optocoupleurs.
Blog électronique : http://battomicro.wordpress.com/
Photographie : www.interactive-celebration.fr

ekaki

#11
Jun 09, 2010, 11:34 am Last Edit: Jun 09, 2010, 11:35 am by ekaki Reason: 1
Quote
Donc, je n'ai rien à faire de spécial si je souhaite avoir une alim externe et de l'usb, si ce n'est connecter mes fils non plus au 5V mais la broche Vin...C'est bien ca ?

Tout à fait -.^
Raccordé à Vin ou à la prise dédiée à cet effet (la grosse prise cinch).

Quote
Mon problème, est qu'actuellement, les fils de nichrome ne reçoivent que 40 mA (limite des pins numériques si j'ai bien compris), ce qui est trop juste.

Ce que j'aimerai, c'est savoir comment réaliser un montage pour que les fils de nichrome reçoivent le maximum de courant...peut-être-faut-il revoir le schéma pour plus d'efficacité (notamment vers la masse?)?

Qu'en penses-tu ?

Comme le suggère B@tto, si tu veux disposer de plus de puissance pour tes commandes par les voies numériques de l'Ardbuino, il va te falloir passer par l'intermédiaire de transistors, d'opto-coupleurs ou de relais.
Ce sont des composants pouvant piloter des commandes qui ont besoin de puissance; pour donner une image, c'est comme si l'Arduino "appuyait" sur un gros bouton qui va lui-même allumer ou éteindre quelque chose.

En fait, il faudrait que tu saches de combien de puissance tu as besoin sur tes voies, cela va déterminer la technologie à utiliser ainsi que le type des composants.
Je dis ça car "avoir le maximum de courant" c'est un peu délicat à interpréter; cela peut être 1A/5V comme 30A/12V, ou 1kW/220V.. ^.^

Pour ta question sur la masse, nous avons toujours tendance à utiliser la masse en opposition au 5V de l'état haut des voies numériques afin de commander des choses derrières..
Cela peut aussi fonctionner en inversé, comme je te le disais, mais on va dire que c'est moins "commun" et en général utilisé pour un type de montage particulier où l'on cherche à commander en inversé : Cela marche tout le temps, et lorsque la commande passe au niveau haut cela coupe en sortie.

Pour te donner une idée, voici un montage type de puissance, avec l'utilisation de la masse, d'un transistor et d'un relais :
http://www.arduino.cc/playground/uploads/Main/relays.pdf
Tu ne seras peut-être pas obligée de passer par un relais, mais bon, c'est pour te montrer la tête du montage -.^

fdufnews

Quote
Ce que j'aimerai, c'est savoir comment réaliser un montage pour que les fils de nichrome reçoivent le maximum de courant.
il faudrait définir clairement ton besoin de ce coté là parce que avec des fils qui ont 1Ohm/cm le courant va se chiffrer en ampères. Et donc cela va conditonner la conception de l'étage de commande.

Jean-François

Avec des Tip120 tu peux déjà passer 5 Ampères....
MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

alexandra

Merci à tous pour vos réponses :)

Après une journée à rechercher des infos sur les transistors, relais et autres...j'ai finalement décidé de me lancer pour un branchement vers VIN, avec, pour le moment une pile 9V..et ça marche  :D

Le nichrome reçoit visiblement ce qui lui faut pour réussir son office ! Je suis contente, premier projet OK.

Ceci dit, je me lance dans un marathon, lol, donc il se peut que je refasse appel à vos compétence prochainement.

A bientôt sur le forum


Go Up