Go Down

Topic: pb pour compiler un sketch avec ubuntu 10.04 (Read 493 times) previous topic - next topic

kriss-38

Depuis mon passage de Ubuntu 9.10 vers 10.04 , il m'est impossible de compiler un sketch dans l environnement arduino 18.
J'ai fait l'essai avec des progs qui se compilaient bien avant.
J'obtiens tout un tas de messages :

"
/home/christian/arduino-0018/hardware/arduino/cores/arduino/pins_arduino.c:409: erreur: expected '=', ',', ';', 'asm' or '__attribute__' before 'PROGMEM'

/home/christian/arduino-0018/hardware/arduino/cores/arduino/pins_arduino.c:432: erreur: expected '=', ',', ';', 'asm' or '__attribute__' before 'PROGMEM'

"

si quelqu'un a une idee , je suis preneur

Merci a tous

kriss-38

Bonjour
La nuit portant conseil, j'ai trouvé ce qui n'allait pas : mon changement de version d'Ubuntu a été fait par une réinstallation pour corriger certains problèmes sur mon PC et j'avais tout simplement oublié de ré-installer avr-libc.
Le problème est corrigé maintenant.
Merci

Go Up