Go Down

Topic: Le bouton Reset et résistance (Read 932 times) previous topic - next topic

demss

Bonjour,

Quand on utilise 1 ATMega on doit mettre une résistance de 10K ohms avec le bouton Reset.


http://www.imagearts.ryerson.ca/sdaniels/physcomp/tutorials/Arduino_standalone/ard_hack.html

Si j'utilise 15 ou 20 ATMegas avec ce même bouton Reset, puis-je utiliser une résistance de 10K ohms?
Sinon quelle sorte de résistance dois-je utiliser?

Merci

fdufnews

#1
Jul 28, 2010, 10:33 pm Last Edit: Jul 28, 2010, 10:34 pm by fdufnews Reason: 1
Le courant de fuite dans une entrée est d'environ 1µA (voir doc ATmega) si on utilise 20 processeurs on a donc un courant d'une vingtaine de µA dans la résistance. La chute de tension dans la résistance de 10k est donc de 200mV. Cela amène l'entrée Reset à 5-0,2 = 4,8V bien au-dessus du seuil bas de l'entrée Reset (0,2 x Vcc soit 1V).
Donc oui on peut utiliser 10k sans problème.

demss

Merci beaucoup fdufnews pour ton aide et tes explications!  :D

demss

#3
Aug 13, 2010, 06:57 am Last Edit: Aug 13, 2010, 06:59 am by userid3456789 Reason: 1
Bonjour,

Ma question est:
Si j'alimente l'ATmega sur 3.3V puis-je également utiliser une résistance de 10K ohms pour le Reset?

Car sur les plans que j'ai trouver il mette une résistance de 1K ohms.
http://www.arduino.cc/playground/Learning/Atmega83-3V


Merci

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy