Pages: [1]   Go Down
Author Topic: Ecran LCD 2x16 HD44780U : problème de resistance  (Read 2229 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Je viens de tester les sketches livrés avec arduino sur mon ecran LCD mais les caractères sont apparus de manière impromptue.

Je ne dispose pas de potentiometre et j'ai donc testé entre le Pin 3 (LCD v0) et la masse plusieurs choses:
. 2 résistance de 4.7Ko et je connecte le V0 entre les 2.
. même chose avec 2 * 10Ko mais 20Ko  me semble affaiblir trop le courant
. 1 résistance de l'ordre du 1ko directement entre V0-->GND

Pourriez-vous m'aider svp merci.
Merci
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 89
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

tu as essayé sans résistance ??
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

oui  sans succes
Logged

France, Nice
Offline Offline
Full Member
***
Karma: 3
Posts: 194
www.Zartronic.fr
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

En supposant que les résistances/potar c'est pour le contraste, même avec un mauvais réglage (Gnd 4,7K <--+--> 4,7K +5V) et tu prends au milieu, tu devrais voir en penchant ton lcd l'affichage de ton texte. (un mauvais contraste fait que l'on voit pas bien juste en face).

Tu as donc peut être un autre problème 'impromptu'  smiley-wink sur la connexion de cet afficheur.

A+ Teiva

www.Zartronic.fr : Votre source Arduino en France
Logged


www.Zartronic.fr : Arduino & Robotique

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Est-il possible par un court circuit d'avoir anéanti le fonctionnement de son contrôleur?

J'ai vérifié les tensions escomptées hormis les Data Pins, ces tensions semblent correctes.


Pin1: GND
Pin2: 5V
Pin3: GND, 2V, ou 5V, dépendant de la résistance  de contraste
Pin4: Pin12 Arduino LCDCrystal
Pin5: GND
Pin6: Pin11 Arduino LCDCrystal
.
DataPins
.
Pin15: 5V
Pin16: GND

Merci pour votre aide
Logged

Geneva
Offline Offline
Faraday Member
**
Karma: 30
Posts: 3231
Yoplait... le pt'it suisse
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Il faut reprendre à la source de ton premier message.

Tu nous dis que ton affichage est "impromptu"... ça ne nous dis pas grand chose, est ce le contraste de l'écran, ou est ce les caractères qui sont bizarre... ou rien du tout.

Comment est fait ton montage, plaque d'essai ou autre....
Logged

MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Le montage est exactement cablé comme le prévoit ce tutoriel:
http://arduino.cc/en/Tutorial/LiquidCrystal

A l'écran je constate au mieux les 16 rectangles de la première ligne en noir lorsque je colle le V0(pin3 lcd) au GND.

Par contre aucun affichage de mot "hello world".

Il ne m'est arrivé qu'une fois de voir apparaitre les caractères blancs avant de constater leur disparition comme une décharge lente de condensateur (normal sur un ecran LCD bleu)
.

L'écran que j'ai acheté est normalement compatible au tutoriel :
http://www.futurlec.com/LED/BLUELCD16x2BL.shtml

Merci pour votre aide  smiley-wink
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Voici le lien d'une photo http://www.img-share.net/uploads/27056211857.jpg
Logged

Geneva
Offline Offline
Faraday Member
**
Karma: 30
Posts: 3231
Yoplait... le pt'it suisse
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Regarde si tu n'as pas un micro court-circuit entre deux soudures.
J'ai eu le cas avec presque les même symptômes que les tiens.
Logged

MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je pense que c'est peut être cela entre le pin1 et 2.
Dans ce cas, apres avoir dessouder avec une pompe speciale que puis je faire de plus pour corriger le tir ?

Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je voudrais juste avoir une confirmation:

OHMETRE (-)  -------Pin1
OHMETRE (+) -------Pin2
Resultat: 3 ohms.

Est-ce que ceci confirme une court circuit entre pin1 et pin2?


NB: Test inverse

OHMETRE (+)  -------Pin1
OHMETRE (-)   -------Pin2
Resultat: infini ohms.
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Une meilleure photo montre que la soudure ne dépasse pourtant pas du pin1 au pin2.
http://www.img-share.net/uploads/60503p1390183.jpg


Je ne sais pas si court circuit il y a ou pas.
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 128
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

J'ai trouvé, tout simplement un cable VDD s'était légèrement déconnecté.
Merci
Logged

France, Nice
Offline Offline
Full Member
***
Karma: 3
Posts: 194
www.Zartronic.fr
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
J'ai trouvé, tout simplement un cable VDD s'était légèrement déconnecté.

Ça c'est du bug 'impromptu'  smiley-grin

On l'a devant le nez et on le voit pas, ça fait partir des grands plaisirs de l'électronique et de la programmation.  smiley

A+ Teiva

www.Zartronic.fr : Votre source Arduino en France
Logged


www.Zartronic.fr : Arduino & Robotique

Pages: [1]   Go Up
Jump to: