Pages: [1]   Go Down
Author Topic: Arduino MEGA et Eclipse  (Read 1200 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut.
J'aimerais programmer l'Arduino sous eclispe mais je n'y arriva pas.
J'ai suivis les instructions trouver sur le net pour utilser eclipse (je compile la librairie dans le projet).
J'arrive a compiler, meme a charger via eclipse mais rien ne ce passe apres...
J'ai fait un Copier/Coller du programme qui fait clignoter la LED et rien...

Quelqu'un a une Idée ou une configuration eclipse qui tourne completement (avec l'exemple de la LED par ex)? (j'arrive pas a en trouver une sur le net... )

merci pour votre aide



PS : voici mon main()

int main(void) {

  /* Must call init for arduino to work properly */
  init();

  /****************************/
  /* Add your setup code here */
  /****************************/

  pinMode(13, 1);

  for (;smiley-wink
  {
        digitalWrite(13, 0);   // set the LED on
        delay(1000);              // wait for a second
        digitalWrite(13, 0);    // set the LED off
        delay(1000);              // wait for a second  

      /****************************/
    /*** write main loop here ***/
    /****************************/
  } // end for

} // end main
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pour être sûr qu'il s'agit d'un pb avec Eclipse, as-tu essayé d'uploader le même sketch via l'IDE Ardino ?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut
Merci pour l'info mais je ne sais pas vraiment comment faire.
Je vais regarder si je trouve des infos.

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

regarde sur arduino.cc
et telecharge leur soft


en plus il y un probleme dans ton code: si tu veux faire clignoter ta led, met la valeur à 1 puis à 0. dans ton code tu la mets 2 fois à 0 .... ca risque pas de marcher
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

NB:
je ne connais pas l'IDE eclipse.

l'IDE arduino marche tres bien...
pour des trucs simples ilest OK, pour des choses plus poussés (liens avec des .h, compilation de .lib )
ou en tout cas ce n'est pas super bien documenté

bienvenue dans la communauté
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut AUREUS
merci pour la reponce.
En ce qui concerne le programme, effectivement ce main ne marchera pas (DSL j'ai posté un Main() pas terrible suite a mes nombreux essai)
Sinon J'ai finalement reussi a utiliser eclipse mais avec un project C++ uniquement (mon premier project qui ne fonctionne toujours pas etait en C)
Donc voila et merci pour votre aide et je vais rester en C++.

Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 66
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

certainement que tu n'avais pas linker le bon compilo ? non ?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Non non, j'ai verifié le projet C et nivo config ca semble bon aussi...
(en meme temps comme j'ai pas trouver le probleme sur le project C je sais pas trop si c'est vraiment cela ou pas...)
 smiley-wink
Logged

Pages: [1]   Go Up
Jump to: