Go Down

Topic: Instabilité standalone (Read 4 times) previous topic - next topic

Berniech

Bonjour et bonne année à tous!
j'ai fait une matrice de leds qui fonctionne bien avec Arduino 2009, mais qui est totalement instable si je l'utilise avec la standalone (qui marche normalement avec blink ): les leds réagissent si j'approche ma main!
Que faire? ajouter une résistance ? mais où?
Merci de votre réponse

Takafuir

Pilotes tu tes led avec des transistors ? Peux tu mètre un schéma de ton câblage ?

Berniech

Oui il y a 1 transistor sur chaque colonne
Je me suis basé sur http://www.instructables.com/id/810-LED-Matrix-with-4017/  avec 2 shifts registers 74 HC595 en série comme dans
http://www.earthshineelectronics.com/files/ASKManualRev4.pdf
Je t'envoie un schéma par e-mail
Merci

Jean-François

Si tu mets ton schéma ici, plus de monde pourra te conseiller  ::)
MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

Takafuir

Je te laisse mètre le schéma, mais je te conseille d'ajouter une résistance assez forte entre bases et émetteurs.

Berniech

#5
Jan 08, 2011, 08:43 pm Last Edit: Jan 08, 2011, 08:59 pm by Berniech Reason: 1
J'ai mis 1 kohm entre émetteur du transistor 2N3904 et le décade counter
4017, comme indiqué par syst3mX
[http://www.instructables.com/id/810-LED-Matrix-with-4017/step3/Multi-what/]
Il faudrait ajouter une résistance entre la base et l'émetteur des transistors???? ça va pas fumer??
Si le schéma ne s'affiche pas, c'est que je n'ai pas compris comment faire!
désolé
encore une explication qui serait bienvenue? ça fait trop?

Hexa Emails

#6
Jan 08, 2011, 08:56 pm Last Edit: Jan 08, 2011, 10:07 pm by MrAlexis44600 Reason: 1
Si le montage fonctionne avec la duelaminove, il vaut peut etre mieux s'intéresser à la "partie standalone" du montage non? comprend-il un quartz?
J'apprends tous les jours!

Berniech

Merci Mr Alexis
Je pense que vous avez raison,  j'ai copié exactement le montage standalone sur le site arduino avec un quartz 16 Mhz et deux condensateurs 22pF.
Il  fonctionne avec "blink"
alimentation en 12 V DC
une idée?

Hexa Emails

Si il fonctionne avec blink, le montage doit être bon. Peut être vérifier à ce moment la correspondance entre les broches de l'ATmega et les n° des PIN de sortie du programme Arduino...
J'apprends tous les jours!

Berniech

J'ai vérifié les connexions; elles sont justes; je vais tout reprendre à zero...demain
en tout cas, merci

Takafuir

#10
Jan 09, 2011, 08:59 am Last Edit: Jan 09, 2011, 11:30 am by Takafuir Reason: 1
Je pense que ton instabilité vient de tes transistors qui commute à la moindre perturbation ex : une main qui s'approche apporte des perturbations électromagnétiques. Le fait d'ajouter une résistance entre la masse et la base va augmenter le courant, si ton courant devient négligeable face aux perturbations alors ton montage sera stable.

Ps: si tu mets les résistances à 3km ça sert à rien, en électronique plus c'est proche mieux c'est. Alors COLLES LES !

EDIT : je pense également que tu peux retirer les résistances entre  les bases et l'arduino SI tu mets les résistances entre les bases et la masse.

Berniech

Je vais essayer la suggestion de Takafuir, mais j'aimerais être sur de bien faire:
mon branchement actuel est comme ça:
10 x transistor 2N3904 NPN
collecteur>>>>ground
base>>>> résistance 1 kOhm>>>> HCF 4017 decade counter
emetteur>>> colonne de LEDS (cathode)

comment devrait-il être éxactement?
quelle valeur de résistance?

Mes excuses pour l'absence de schéma; je n'ai pas NON PLUS
compris comment le poster!
Merci d'avance de votre aide

fdufnews

Quote
Mes excuses pour l'absence de schéma; je n'ai pas NON PLUS
compris comment le poster!

Il faut placer l'image sur un site d'hébergement comme http://up.sur-la-toile.com par exemple. Et il faut placer le lien vers la page créée dans la balise "insert image" (3ème icône dans la barre au-dessus de la fenêtre d'édition.

Berniech

j'essaye
http://[url=http://up.sur-la-toile.com/sHL3][img]http://up.sur-la-toile.com/vHL3[/img][/url]
Si quelqu'un peut me dire quelle valeur et où mettre les résistances de tirage ????
Merci

Berniech

J'ai mis 4,7 k entre base et masse de chaque transistor et j'ai enlevé les
1k qui étaient entre base et 4017. le circuit est stable et rien ne se passe
quand on approche la main.
C'est un progrès certain!
Par contre la matrice ne fonctionne toujours pas en standalone, alors qu'elle fonctionne sur l'Arduino...
Une idée???

Go Up