Pages: [1]   Go Down
Author Topic: Linux problem with arduino UNO  (Read 5996 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I bought my arduino UNO starter kit. it works perfectly fine on windows 7 but I cant upload the software from arduino IDE to the arduino board when using linux. I have tried linux mint 10 , ubuntu 10.10 and fedora 14 all of them have the same problem. Sometimes /dev/ttyACM0 is detected and most of the time its not. When it does detect it and I chose to upload to the board it either says ACM0 not found or ACM0 is already in use. Only once I was actually able to upload to the arduino UNO using linux mint (arduino 0021) but after that I have tried numerous solutions and nothing works.

I have tried using a self-powered usb hub to connect my arduino UNO board to the PC but no luck. Basically I connected an IR distance sensor to the arduino and programmed it using windows just to see if it communicates back to the PC in linux and it was only successful in doing so once. I got a reading for distance in cm on the serial monitor by moving my hand closer and away from the sensor. otherwise I have had absolutely no luck in uploading to the board. I even tried to use arduino-0022 and replace librxtxSerial.so and RXTXcomm.jar using both 0021 and 0022 but nothing works !

any suggestions ? I really want to use linux

Thank you.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I used this website: https://sites.google.com/a/lyz.jp/arduino/about-arduino/arduino-setup-for-fedora14 and the arduino.cc playground to setup my arduino IDE and both failed.

I have tried the soltuions listed here: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1292104213
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

When you get the error message that the serial port is already in use, run this command:

"lsof | grep ttyACM0"  (or change ttyACM0 to whatever your Arduino's serial port is.)

What processes are listed as using the serial port?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Colorado
Offline Offline
Full Member
***
Karma: 2
Posts: 220
Arduino 0022 and Ubuntu 11.10 64bit.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

on ubuntu 10.10 could you plug the usb port in and run this command
dmesg | grep usb

pls post the output


Logged

Pages: [1]   Go Up
Jump to: