Go Down

Topic: Installing Arduino IDE 0022 on Ubuntu 10.04 LTS 64bit for Arduino Uno (Read 3 times) previous topic - next topic

noisybit

Hello community,

I've had trouble to get Arduino IDE up and running on my system. However, I think I solved it and I wanna share my solution with you.

Go to https://launchpad.net/ubuntu/natty/+source/arduino
At the right side there are links to binary files listed. That is "arduino-core" and "arduino". Follow the links or if you want to get the 64bit version, go directly to:


Install "arduino-core" then "arduino". This is because "arduino" requires "arduino-core" to be installed before.

That installation was quick, wasn't it? Now you can start up the IDE from Ubuntu's menu Applications > Programming > Arduino IDE.

After that installation I found out that Tools > Serial Port was grayed out.


I found out that /dev/ttyACM0 is the device (Arduino Uno) I wanna talk to. I was able to execute ...
Code: [Select]
echo "ciao" > /dev/ttyACM0
... and see the RX led blinking. Thus at least there was a reaction, basically a connection was possible.

To cut a long story short ... I tried several ways to get /dev/ttyACM0 visible in that menu. In the end all I needed to change was adding a symbolic link. I created that with ...
Code: [Select]
sudo ln -s /dev/ttyACM0 /dev/ttyS10
I choosed ttyS10 because ttyS0 was already occupied.

After restarting the Arduino IDE, the menu item Tools > Serial Port became enabled and I had /dev/ttyS10 as an entry in there. Then I uploaded "Examples > Basics > Blink" and Arduino started blinking.

Please respond if this short description helped you too.

Regards

purza

Arduino UNO that seems selfish about sending back serial data!
KUBUNTU 10.10 AMD64

mrtaylor

Hello noisybit,  can you tell me what kernel version you are running?  Thanks

purza

Noisybit,

Your instructions worked!  The only issue I have is I have to run
Code: [Select]
sudo ln -s /dev/ttyACM0 /dev/ttyS10 every time I start the Arduino software.  I'm new to Linux and not sure what the work around would be for this.

FYI: I'm running KUBUNTU amd64 10. something.

I had the Arduino running earlier with the help of a couple of posts in the old forum.  http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1293243021/0  I had run it from the directory that I installed it using "dolphin".
Arduino UNO that seems selfish about sending back serial data!
KUBUNTU 10.10 AMD64

mellis

There's an updated version of the RXTX package for Debian / Ubuntu (rxtx (2.2pre2-3)) that adds support for the /dev/ttyACM* devices. 

https://launchpad.net/ubuntu/natty/+source/rxtx
https://launchpad.net/ubuntu/natty/+source/rxtx/+changelog

I'm not sure if it's been backported to any of the shipping distributions yet or what you'd need to do to install it.

noisybit

Hi all,

Machine hardware name:
Code: [Select]

noisybit@noisybit-desktop:~$ uname -m
x86_64


Kernel release:
Code: [Select]

noisybit@noisybit-desktop:~$ uname -r
2.6.32-28-generic


Kernel version:
Code: [Select]

noisybit@noisybit-desktop:~$ uname -v
#55-Ubuntu SMP Mon Jan 10 23:42:43 UTC 2011


purza, you're right. After rebooting the link was gone. Creating the link / alias automatically right after plugging in Arduino Uno may be solved with some udev rules - but frankly I've no idea how it works. But wait until you read next paragraph ...

Now I downloaded and installed the package that mellis pointed to. And ... it worked! I now can see the /dev/ttyACM0 as menu item. So there is no need anymore to have the workaround with the symbolic link.

FransK

I had the same problems when I started with Ardunio this weekend (using openSuse 11.3/64).
Creating a symbolic link using option -S will forget it on reboot. But making a permanent in in this system controlled directory is not advisable.

I found here http://andypiper.co.uk/2010/12/21/prototyping-arduino-and-ubuntu/ the instruction for a proper solution: define a rule in the USB configuration. I copied the relevant text below.
Success.

Quote
Creating static symbolic links in /dev is a bit hokey these days, of course, so I moved across to udev and created a new rule for the UNO in a file called /etc/udev/rules.d/80-arduino-uno.rule

KERNEL=="ttyACM*", ATTRS{product}=="Arduino*", SYMLINK+="ttyUSB%n"

dead simple: if a new device pops up in the kernel named ttyACMsomething, and it has a USB product ID string starting Arduino (which mine does, I checked using the command usb-devices), add another symlink to it at ttyUSBsomething, thanks. Result:

Dec 21 19:18:50 agrippa kernel: [21501.209012] usb 1-1.1: new full
speed USB device using ehci_hcd and address 17
Dec 21 19:18:50 agrippa kernel: [21501.303198] cdc_acm 1-1.1:1.0:
ttyACM0: USB ACM device
andyp@agrippa:/etc/udev/rules.d$ ls -l /dev/ttyU*
lrwxrwxrwx 1 root root 7 2010-12-21 19:18 /dev/ttyUSB0 -> ttyACM0

purza

Noisybit and Mellis,

Excuse my ignorance, but how do I install the file(s) https://launchpad.net/ubuntu/natty/+source/rxtx

It would seem I just need to download the latest version "rxtx_2.2pre2-3.debian.tar.gz" and then install it.   But from where... and how...  I've done this before, but having trouble remembering exact procedure. 

Thanks.

Working on this stuff as a hobby in my spare time... when I'm not doing my real jobs, servicing electron microscopes and keeping up the household.
Arduino UNO that seems selfish about sending back serial data!
KUBUNTU 10.10 AMD64

unprinted

#8
Feb 09, 2011, 10:29 pm Last Edit: Feb 09, 2011, 10:35 pm by unprinted Reason: 1

There's an updated version of the RXTX package for Debian / Ubuntu (rxtx (2.2pre2-3)) that adds support for the /dev/ttyACM* devices.  

..

I'm not sure if it's been backported to any of the shipping distributions yet or what you'd need to do to install it.


With 64-bit Ubuntu 10.10, it works, but that may be because of the library with the Arduino version 21 and 22:

Code: [Select]

WARNING:  RXTX Version mismatch
Jar version = RXTX-2.1-7
native lib Version = RXTX-2.2pre2


I did have problems with Arduino 21 and Unos on 32-bit Ubuntu, but my solution was just to use Duemilanoves :)

For Arduino 22 on 64-bit Ubuntu, it is currently necessary to copy the arduino-0021/lib/librxtxSerial.so from the 64-bit version of Arduino 21 to arduino-0022/lib/, overwriting the (32-bit) .so currently there.

purza



If I understand you correctly. I need to copy this jar file "RXTXcomm.jar" from the 0021/lib folder to the arduino-0022/lib/ folder?
Arduino UNO that seems selfish about sending back serial data!
KUBUNTU 10.10 AMD64

noisybit


Excuse my ignorance, but how do I install the file(s) https://launchpad.net/ubuntu/natty/+source/rxtx


First sorry for my late response.

Installation ...


The installation alone worked for me. No additional links in /dev folder, nor copying files around by myself.


purza

Arduino UNO that seems selfish about sending back serial data!
KUBUNTU 10.10 AMD64

Go Up