Pages: [1]   Go Down
Author Topic: Arduino 17 no longer starting  (Read 2385 times)
0 Members and 1 Guest are viewing this topic.
Herefordshire
Offline Offline
Newbie
*
Karma: 0
Posts: 36
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I was using Arduino 17 since it was released but last week, I seemed to have problems starting the serial monitor, then it seemed to stop responding.  Now when I try to start the Ardiono 17 software, I just get the splash screen, it appears for a long time, then a message pops up saying that it can be it cant be started .

Does anyone know what might have happened?  I tried deleting and reinstalling it. No progress.  I can still start the older versions.

Id be grateful for any advice.
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 614
Posts: 49343
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you upgraded Java? The Java that comes with the IDE seems to no longer be the latest version. If you have a newer version than the one delivered with the IDE, all kinds of strange problems can occur. Delete or rename the Java folder in the IDE directory. See of that solves the problem.
Logged

Herefordshire
Offline Offline
Newbie
*
Karma: 0
Posts: 36
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks, I shall give it a try although I doubt it would be that because it stopped working while I was using it and I wasn't connected to the internet for the Java to be updated.
Logged

Herefordshire
Offline Offline
Newbie
*
Karma: 0
Posts: 36
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried the above, still no luck. I even reinstalled jre again and whilst arduino 16 works, version 17 is still not starting.  I re-installed Arduino 17 yet again and still no success. Does anyone have any other ideas. Thanks.
Logged

Herefordshire
Offline Offline
Newbie
*
Karma: 0
Posts: 36
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Eventually I get a popup "launch4j"  There was a problem starting the application.  Or something along those lines.  

I reinstalled launch4j, still the same problem.  Its really frustrating!  Im havinging to resort to version 16 till version 18 is released.
Logged

UK
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I recently posted suspicions of vista/java clash which might have prevented compiler working properly... I had a clear out of  processing and avr files collected from elsewhere and re installed ard0017 from scratch. So far everything works now.  I now feel the clash was within the ragbag of discarded generic files . I may bring them back from the RB one by one to verify....  Sorry to have spread wrong  ideas.
By the way, a diode connected + to gnd and fed  5V via 220K res. makes a cheap linear temp. sensor, a few mV  per degree C around 400mV .
Logged

Herefordshire
Offline Offline
Newbie
*
Karma: 0
Posts: 36
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Some more info on the Arduino 17 problem.  Im using Windows XP.  I tried to plug in my arduio into another PC with arduino 17 and that also failed to start.  A popup "Launch4j" comes up again stating that the application could not launch.

I seems that the arduino may have become faulty but I still dont know why this would happen.

When trying to use the arduino board with Arduino 16 software, the program runs up to the point where I expect serial output to the serial monitor.  When I tried another board, it worked fine under version 16.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try renaming your arduino folder, my documents/arduino to something else.
Logged

Wuppertal/Germany
Offline Offline
God Member
*****
Karma: 1
Posts: 895
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi jfp,
Quote
I recently posted suspicions of vista/java clash which might have prevented compiler working properly...
Where was that?
Eberhard


Logged

Lancashire, UK
Offline Offline
Edison Member
*
Karma: 9
Posts: 1991
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

What happens if you don't connect the Arduino and run the 0017 ?

It doesn't need a board to be connected to run.
Logged


Herefordshire
Offline Offline
Newbie
*
Karma: 0
Posts: 36
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It still doesnt start when there is no board plugged in.  I tried deleting it and putting a fresg copy on my PC, same problem.  I think is something to to do with the launch4j software.  I get the splash screen/picture but nothing else. smiley-sad
Logged

Wuppertal/Germany
Offline Offline
God Member
*****
Karma: 1
Posts: 895
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Could you try to start the IDE from the commandline. The program  might print some error messages to the console before it dies.

Deleteing the preferences.txt file for the IDE might also be worth a try. It is not removed whe you wipe an old version, by deleting the folder where the arduino is installed.
Eberhard
Logged

Herefordshire
Offline Offline
Newbie
*
Karma: 0
Posts: 36
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Eberhard, I deleted the Preferences.txt file and it worked!!!

Thank you!!

Now I'd like to find out what is wrong with the arduino board I was using.  I shall try putting another sketch onto it and see if it stops the software working again.
Logged

Pages: [1]   Go Up
Jump to: