Go Down

Topic: Introducing the Webduino web server library (Read 42241 times) previous topic - next topic

FrankM

Oh I see... To the OP: if this is not yet resolved, can you try tapping into the request that is sent through the browser? In firefox you can use extensions LiveHTTPHeader, TamperData, firebug and/or webdeveloper for this.

omegatron

yeah, I was using tamperdata in FF to confirm that the value "1" in this case, was being correctly sent, however the value reported on the arduino serial output would always show up twice.

Eg: 11  or 22

I'll have to put it back together again to test further, I've been working on a couple of other boards/sketches while planning to come back to this when I've got more time to go over it all to understand it better :-)

FrankM

When you get back at testing, try adding an extra parameter (input type hidden) with a fixed value. Also try to give led a string value ('one'). That way you can see what exactly is duplicated. Also test (in your code) if led does get set to 11. I'll follow this topic to see if you get any usable results for futher ideas...

razorbob

Hi !

Did someone tried Webduino lib on Arduino 019 ?
I'm trying to use Webduino over new Ethernet microSD shield but looks like that's no more compliant... :(

chewie

Good luck. I can't get it to compile any more. I could build and run Web_Demo on Arduino0017 but not under 19.

Error message
Code: [Select]

In file included from /home/matt/_DEV/arduino19/arduino-0019/libraries/Ethernet/Server.cpp:1:
/home/matt/_DEV/arduino19/arduino-0019/libraries/Ethernet/utility/w5100.h:14:17: error: SPI.h: No such file or directory

As of Arduino 0019, the Ethernet library depends on the SPI library.
You appear to be using it or another library that depends on the SPI library


Not sure witch bits to hack about next  :'(

Chewie

Glyphi

Yup, my SPI project fails on 019 and 020 as well, they have included an SPI library in these versions that uses different case and different setting function names.

I've looked for documentation on the changes but have not seen any yet.

I should be trying to solve this sometime this week, if I do I'll post info here. If you beat me to it I hope you do too!

Good luck.

Glyn

mellis

I did Sketch > Import Library > SPI and the Web_Demo example worked fine for me in Arduino 0021 (webduino 1.4.1).  It just adds this line to the top of your sketch: #include <SPI.h>

The documentation for the SPI library is here: http://arduino.cc/en/Reference/SPI

Glyphi

Ah, one of mine calls a routine called 'mode' in the old version. It doesn't seem to exist in the new.

Thanks for the definitive first step!

Glyn

chewie

mellis you are a star !

Worked a treat  8-) now I just have to sort out the WebServer.h not found but that is covered on the Webduino home page.

Cheers

Go Up