Go Down

Topic: Problem on uploading code into esp8266 nodemcu (Read 241 times) previous topic - next topic

lsiddiqsunny

Recently I bought a esp8266 nodemcu for my project.
For running the blink code, I followed this tutorial esp8266 quick start. But ended up with this  :

Quote
Sketch uses 246,319 bytes (23%) of program storage space. Maximum is 1,044,464 bytes.
Global variables use 32,276 bytes (39%) of dynamic memory, leaving 49,644 bytes for local variables. Maximum is 81,920 bytes.
Uploading 250464 bytes from C:\Users\test\AppData\Local\Temp\build544514107263874658.tmp/arduinowifi.cpp.bin to flash at 0x00000000
.error: failed sending 1044 bytes
error: failed sending 0xC0
warning: espcomm_send_command: didn't receive command response
warning: espcomm_send_command(FLASH_DOWNLOAD_DATA) failed
error: failed sending 0xC0
error: failed sending 8 bytes
error: failed sending 4 bytes
error: failed sending 0xC0
warning: espcomm_send_command: didn't receive command response
error: espcomm_upload_mem failed
I tried with different baud rate but failed.
Arduino IDE: 1.6.5 and 1.8.5
OS: Windows 10 and Linux 16.04LTS

Delta_G

Also posted on ASE.  If you're going to sprinkle the same question all over the Internet, at least be considerate enough to link them so nobody wastes their time giving you answers you already have. 
|| | ||| | || | ||  ~Woodstock

Please do not PM with technical questions or comments.  Keep Arduino stuff out on the boards where it belongs.

kennethgomad02

this happen most in pins maybe you place it wrong or the codw that you were trying to upload is not forfortable for thr nodemcu so it wont accept it.

Go Up