Go Down

Topic: Windows/Linux/Mac Eclipse plugin to compile and upload arduino sketches (Read 307796 times) previous topic - next topic

JimInWoodstock

I am used to a dark theme when coding. I also am new to the plugin and eclipse. I have been using the Arduino IDE in the past. I installed the Moonrise UI and it shows up in the installed plugin list. However, when I go to windows, appearance I don't see the moonrise UI theme. In general, how to I get this to work and how do I find other dark themes that might be available?

Problem solved. Read the docs more carefully.

Jantje

Great :-)
Another problem solved.
Thanks for reporting success
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

nbarbet

Good morning, I have trouble building a shared Arduino project with Google Drive using Eclipse with the plug-in for Arduino. I created an empty Arduino project in Eclipse environment of PC and imported to the folder with the real Arduino project present in Google Drive, but I can not connect this project in Eclipse ... I would to share the project of Google Drive on two platforms (Mac and PC) Each one with Eclipse installed ... at the moment I can modify the project "shared" with Eclipse and then compile with Arduino compiler, but I can not with the Eclipse compiler ... thanks, Nicola

Jantje

@nbarbet
I don't think that will work as the .project and .cproject are OS dependent.
Why don't you use a version control system like github. That works great if you checkin a initial .project and .cproject and then add those to the .ignore file
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Arrowmax

Jantje, Could you please share printscreens of your settings for the Arduino Zero in Sloeber?
Your youtube video describes how to debug the ESP8266, but I get an error using OpenOCD with Arduino Zero: No source available for "0xfffffffe"

Jantje

I do not have print screens. I also can not make printscreens/videos of my work as I don't us the zero.
Actually I'm hardly doing any arduino work right now. Most of it is maintaining sloeber.
Making a zero debugging video on my todo list but so is 4.0 new and noteworthy :-(
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

darthbolek

Linux Fedora 25 64-bit install tips.

1. for serial access add user to groups: lock, dialout
sudo usermod -a -G lock <user>
sudo usermod -a -G dialout <user>

2. avrdude is missing libtinfo.so.5 library. The green color and line "upload done" is a little misleading... I'd expect red and "failure" :)

arduinoPlugin/packages/arduino/tools/avrdude/6.3.0-arduino8/bin/avrdude: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory
avrdude finished
upload done

In F25 there is version 6 only. Adding link 5 -> 6 solves avrdude runtime problem. It might have impact on stability of avrdude and/or other software.
sudo ln -s /lib64/libtinfo.so.6.0 /lib64/libtinfo.so.5

Code: [Select]
[xxx@yyy sloeber]$ ldd arduinoPlugin/packages/arduino/tools/avrdude/6.3.0-arduino8/bin/avrdude
 linux-vdso.so.1 (0x00007ffc5b0c7000)
 librt.so.1 => /lib64/librt.so.1 (0x00007f5e00f2e000)
 libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f5e00d10000)
 libm.so.6 => /lib64/libm.so.6 (0x00007f5e00a07000)
 libtinfo.so.5 => not found
 libc.so.6 => /lib64/libc.so.6 (0x00007f5e00641000)
 /lib64/ld-linux-x86-64.so.2 (0x000055b879390000)

xxx@yyy sloeber]$ ls -l /usr/lib64/libtinfo*
lrwxrwxrwx. 1 root root     15 Jul 19  2016 /usr/lib64/libtinfo.so.6 -> libtinfo.so.6.0
-rwxr-xr-x. 1 root root 180200 Jul 19  2016 /usr/lib64/libtinfo.so.6.0

[xxx@yyy sloeber]$ sudo ln -s /lib64/libtinfo.so.6.0 /lib64/libtinfo.so.5

[xxx@yyy sloeber]$ ls -l /usr/lib64/libtinfo*
lrwxrwxrwx  1 root root     22 Feb 28 12:51 /usr/lib64/libtinfo.so.5 -> /lib64/libtinfo.so.6.0
lrwxrwxrwx. 1 root root     15 Jul 19  2016 /usr/lib64/libtinfo.so.6 -> libtinfo.so.6.0
-rwxr-xr-x. 1 root root 180200 Jul 19  2016 /usr/lib64/libtinfo.so.6.0




After these my Sloeber is programming boards now.

Jantje

@darthbolek
Thanks for fixing your problems yourself and thanks for sharing :-)
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

lafleur

I just installed Sloeber and it looks great...

But when I try to compile my project, the IDE 1.8.0 reference to processor type do NOT appear in Sloeber..

Like:
 
__SAMD21G18A__
ARDUINO_ARCH_SAMD

ARDUINO_ARCH_AVR



did I miss something during the install??

thanks

Jantje

Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

JimInWoodstock

I have a sketch that I developed in the arduino ide. I want to migrate this to the sloeber ide and discontinue using the rather primitive arduino ide. However, I get quite a few errors regarding the included libraries. I am attaching a zip file containing the code and the errors. Please take a look and let me know what I did wrong.
Thanks

Jantje

Please take a look and let me know what I did wrong.
My hourly rate is 100 euro exclusive VAT.  8)
How much time do you want me to spend on this?  :smiley-evil:
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

pito

Installed Sloeber today, the V4. Updated via nighty.
When trying to install the j-link plugin from your http://eclipse.baeyens.it/update/V4/nightly I get:

 
Code: [Select]
Cannot complete the install because of a conflicting dependency.
  Software being installed: GNU ARM C/C++ J-Link Debugging 4.1.1.201606210758 (ilg.gnuarmeclipse.debug.gdbjtag.jlink.feature.group 4.1.1.201606210758)
  Software currently installed: Sloeber, the Eclipse Arduino IDE 4.0.0.201701171403 (io.sloeber.product 4.0.0.201701171403)
  Only one of the following can be installed at once:
    GNU ARM C/C++ Debugger Restart Button 1.3.1.201606210758 (ilg.gnuarmeclipse.debug.gdbjtag.restart 1.3.1.201606210758)
    GNU ARM C/C++ Debugger Restart Button 1.3.1.201701170259 (ilg.gnuarmeclipse.debug.gdbjtag.restart 1.3.1.201701170259)
  Cannot satisfy dependency:
    From: GNU ARM C/C++ J-Link Debugging 4.1.1.201606210758 (ilg.gnuarmeclipse.debug.gdbjtag.jlink.feature.group 4.1.1.201606210758)
    To: ilg.gnuarmeclipse.debug.gdbjtag.restart [1.3.1.201606210758]
  Cannot satisfy dependency:
    From: GNU ARM C/C++ OpenOCD Debugging 4.1.2.201701170259 (ilg.gnuarmeclipse.debug.gdbjtag.openocd.feature.group 4.1.2.201701170259)
    To: ilg.gnuarmeclipse.debug.gdbjtag.restart [1.3.1.201701170259]
  Cannot satisfy dependency:
    From: Sloeber, the Eclipse Arduino IDE 4.0.0.201701171403 (io.sloeber.product 4.0.0.201701171403)
    To: ilg.gnuarmeclipse.debug.gdbjtag.openocd.feature.group [4.1.2.201701170259]

Any hint how to get segger into debug configurations?

Jantje

This issue has been discussed here https://github.com/Sloeber/arduino-eclipse-plugin/issues/665
I havn't been able to dive into why this problem exists but it is related to part of gnuarmeclipse being in the plugin for debugging.
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

pito

J-link plugin issue - The nightly built from April 1st has done it (win7 64b here)..

Go Up