Go Down

Topic: Can't find COM port for Arduino UNO (Read 12436 times) previous topic - next topic

islamhasan

I Can not find COM port for Arduino UNO
It was Arduino UNO is working properly and when I finished them I added Arduino Nano place taking into account the change Board and when I finished I wanted to refer to the Arduino UNO and when I wanted to Upload code did not I can promise has COM6 disappeared attributed Arduino Nano appeared but Arduino UNO does not and LED ON is shines.

ron_sutherland

Windows will reserve ports (based on VID and PID of the USB device I think) and sometimes that can become confusing. Look on the internet for ways to release them.  Bellow is a how to:

        
        1) Open Command Prompt as Administrator (you may need to research how to do this for your version of windows).

        2) (this step is not needed on Windows 10 but is on 7) Set Environment variable  "set devmgr_show_nonpresent_devices=1".
            At the command prompt, type the following command and then press ENTER:

            set devmgr_show_nonpresent_devices=1

        3) Run Device Manager with Environment variable. Type the following at command prompt, and then press ENTER:

            start devmgmt.msc

        4) Show hidden devices. Point to View and left click, then point to
            Show hidden devices and left click. This will display reserved ports.

        5) View hidden COM ports. Go to Ports (COM & LPT) and expand that
            section.

        6) Remove COM1. Remove COM1 device in the list of ports, and optionally others
            that are grayed out but have a specific COM port number assigned. Right click
            on the grayed out device, choose Uninstall, and then OK in the dialog box that
            appears.

        7) Close Device Manager.

        8 ) Exit command prompt.

ballscrewbob

Windows will reserve ports (based on VID and PID of the USB device I think) and sometimes that can become confusing. Look on the internet for ways to release them.  Bellow is a how to:

        
        1) Open Command Prompt as Administrator (you may need to research how to do this for your version of windows).

        2) (this step is not needed on Windows 10 but is on 7) Set Environment variable  "set devmgr_show_nonpresent_devices=1".
            At the command prompt, type the following command and then press ENTER:

            set devmgr_show_nonpresent_devices=1

        3) Run Device Manager with Environment variable. Type the following at command prompt, and then press ENTER:

            start devmgmt.msc

        4) Show hidden devices. Point to View and left click, then point to
            Show hidden devices and left click. This will display reserved ports.

        5) View hidden COM ports. Go to Ports (COM & LPT) and expand that
            section.

        6) Remove COM1. Remove COM1 device in the list of ports, and optionally others
            that are grayed out but have a specific COM port number assigned. Right click
            on the grayed out device, choose Uninstall, and then OK in the dialog box that
            appears.

        7) Close Device Manager.

        8 ) Exit command prompt.

This should be a sticky !

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

islamhasan

Windows will reserve ports (based on VID and PID of the USB device I think) and sometimes that can become confusing. Look on the internet for ways to release them.  Bellow is a how to:

        
        1) Open Command Prompt as Administrator (you may need to research how to do this for your version of windows).

        2) (this step is not needed on Windows 10 but is on 7) Set Environment variable  "set devmgr_show_nonpresent_devices=1".
            At the command prompt, type the following command and then press ENTER:

            set devmgr_show_nonpresent_devices=1

        3) Run Device Manager with Environment variable. Type the following at command prompt, and then press ENTER:

            start devmgmt.msc

        4) Show hidden devices. Point to View and left click, then point to
            Show hidden devices and left click. This will display reserved ports.

        5) View hidden COM ports. Go to Ports (COM & LPT) and expand that
            section.

        6) Remove COM1. Remove COM1 device in the list of ports, and optionally others
            that are grayed out but have a specific COM port number assigned. Right click
            on the grayed out device, choose Uninstall, and then OK in the dialog box that
            appears.

        7) Close Device Manager.

        8 ) Exit command prompt.

Thanks you but it did not work.

ballscrewbob

I followed the advice but went further.

1. Disconnect as many USB devices as possible.
2. Do as Ron said but here is where I went OTT I deleted every COM port.
3. Ran "wise" registry cleaner
4. Ran CCLEANER too
5. Re-boot computer and start adding in the USB devices you disconnected one by one (slowly) until they        are all back up and running
6. Connect one Arduino and if it shows up and installs its needed drivers then fine I tried the BLINK      sketch
7. If it did not work correctly then I went and got the 340/341 drivers and installed them and did another re-boot then step 5. again.

Only issue I have had since was with an older WI-FI adaptor which is the one I am playing with to connect to ESP8266 devies right now. Its hit and miss at being recognised at the best of times. Otherwise it helped out a great deal. There is for sure something with IDE 1.6.6 that messes up USB and the Arduinos.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

AmirKatz

Unplug the USB and plug it to different socket.

That worked for me.

fugu

I was having problems where it kept trying to use COM 10, which did not work.  (Windows 7)
In Device Manager, I opened Properties on Arduino Uno (COM3) under Ports (COM & LPT) 
Then Port Settings, Advanced, and Click COM Port Number button.  It showed a list of port numbers, but all the ones below COM10 were marked In Use.  I could force it to pick a lower number after answering Yes on a couple warnings, but the next time I used a different board, it wanted to use 10 again.

Solution:
1. Device Manager main page: Right click the port and select DISABLE
2. Go into the advanced properties port selection, and select each of the in-use ports and accept the warnings.  This clears the in use flag.
3. Select the port number you want to use in Properties, close it, then enable the port again in Device Manager.

Now all the port numbers will be free to use until they get tied up again for whatever reason.   

Go Up