Go Down

Topic: MacOS Sierra does not find USB connection to FTDI (Read 15873 times) previous topic - next topic

eeduard

#15
Dec 28, 2016, 10:40 pm Last Edit: Dec 29, 2016, 03:32 pm by eeduard
I have a good news for all, who have a problem with USB Serial Port on macOS Sierra :smiley-cool:
Here a link which help you solve this issue!

NOTE: It's works on 10.12.3 (16D17a) version. If it's does not help and your version OS less than mine, then necessary use previous driver version, which you can find there: previous ver. If you got an error in terminal for sudo nvram boot-args="kext-dev-mode=1", then boot in recovery/restore mode and use that without sudo - like so nvram boot-args="kext-dev-mode=1". In case you do this things right, then you got no error message, you got nothing except, I don't remember correctly, but something like #bash.

P.S. Do not forget look at a description of video to find a link to driver installer ;)

Best regards

watski

Crossposting from my reply on the Apple support forum. hope no-one minds.

I had a similar problem after upgrading to Sierra. My FT232s would work after a reboot but if I disconnected and reconnected them they would not reappear. I installed the official FTDI drivers (v2.3), removed Apple's driver and rebooted.

Code: [Select]
sudo mv /Library/Extensions/FTDIKext.kext ~/

Now I can disconnect/reconnect my FT232 boards again :)

ronnyandre

I have the same issue. No drivers are working for me...

eeduard, did you solve your problem?

rodrigocbv

I have the same issue.
It was working fine and all of a sudden the arduino software cannot find the usb ports anymore. It only shows a bluetooth port. My mouse, however, is plugged into a usb port and it works fine. I have also connected my iPhone to one of the usb ports and it also works without an issue.
I've read people talking about going back to built in apple FTDI drivers. How do we do that?

Thanks!

dethswatch

On Sierra, I had to go to:
/library/extensions/

and remove:
usbserial.kext
D2xxHelper.kext

LEAVING:
FTDIUSBSerialDriver.kext

Then reboot and it started to work for me...

walterfantauzzi

Hi Guys I'll become crazy with the same issues on my mac os x sierra. I've install the FTDI chip USB drivers but I can't connect my Prusa i3 with my mac.


vegetalpt

Hi Guys Help please, I'll become crazy with the same issues on my MacBook pro macOS  Sierra 10.12.4, my ARDUINO UNO don't work ... no Serial port... what i can do???
Please help...

neeraj87

Hi, itsnotsara!
I have same problem on macOS Sierra - have no serial port  :(
If I'll find solution, I will share here
Did you find any solution to this?

falsanu

Hi,

I found a solution which worked for me.

I've downloaded the driver from elegoo (http://www.elegoo.com/download/ - select Uno Nano) and this one brought up the device /dev/tty.wchusbserial1410

Mac OS X Sierra 10.12.6

Hope this helps.

BR
Falsanu

bernmc

Thought I'd confirm that deleting all third party FTDI drivers, including wacom tablet and official FTDI, worked for me. ie the native apple drivers will (currently) talk to chinese copy chips.

I'm running MacOS High Sierra v10.13beta

Go Up