Go Down

Topic: Cant Debug Arduino Zero - error No source available for "0xfffffffe"  (Read 373 times) previous topic - next topic

Arrowmax

Hi!

I'm stuck with debugging my arduino zero in eclipse...

Using openOCD and GDB in a terminal I can debug my arduino Zero.
See: http://starter-kit.nettigo.eu/2015/debug-sketch-on-arduino-zero-pro-with-gdb-and-openocd/
But when I configure eclipse using the Arduino plugin and GNU ARM openOCD i get the following error: No source available for "0xfffffffe"

Log:
Warn : keep_alive() was not invoked in the 1000ms timelimit. GDB alive packet not sent! (1390). Workaround: increase "set remotetimeout" in GDB
target halted due to debug-request, current mode: Thread
xPSR: 0x81000000 pc: 0xfffffffe msp: 0xfffffffc

Any ideas :smiley-mr-green:



Arrowmax

Still stuck at the same problem. I'm using the Arduino Zero cc version.

SurfingDude

The Arduino Zero from .cc comes with Atmel's EDBG chip and is nicely supported by Atmel Studio (free download). This gives you breakpoints, single stepping, and all. Why are you using Eclipse?

westfw

Are those the magic return addresses cortex m uses for exception handling?

Arrowmax

Debugging using Atmel Studio 7 works great. But, Atmel Studio is Windows only and I want to work on Mac OS X.

It is working using the latest OpenOCD: OpenOCD Arduino.cc

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy