Go Down

Topic: Due appears as COM6 port but gives error "No device found on COM6" on upload (Read 40574 times) previous topic - next topic

marcovansteen

Hey Willie,

You're The Man !!

This is exactly what fixed it in my situation.
In my setup I pulled the RX0 pin down to GND with a 1 kOhm resistor.

Aparently the 16U2 can pull this RX pin to GND using IC10.
Apart from the programming issue, to me it looks a bit "rude" to short an input and possibly overload external devices sending into RX pin.

Another suspect thing is the timing of IC10 especially since the input and "not(output enable) pins are shorted. Now the propagataion delay will determine what happens.
When the input (net 16U2-TX) toggles from low to high, the output may go: low->high->high-Z. With a pull-down resistor the high-Z becomes 'low'. so low->high->low instead of an intended low->high-Z.
Maybe this corrupts the SAM's UART state.
Any way this is just a theory that I did not test.

Marco

Dmitry_Ai

Sorry, but I didn't found the answer if I have a problem "No device found on COM3" what I need to do.

:(

May be I don't understand some of topics?

I tried to press "erase" and "reset" but nothing happens.

Go Up