Thanks avandalenI've downloaded your updated Delay library from GithubGithubI'm going to start playing with it.The thought of the Delay() stopping code execution drives me crazy. CheersRick Hubkatry the new version, everything is tested
Hi!Does it work with Leonardo?According description it's great but can't compile
Maybe we can change just the names of some functions to make it better understandable?
Hi,Yes, I think that the actual names of methods can make a great deal of difference to the usability of a class.In some cases it might be handy to simply provide some aliases for different use-cases (I know there are different opinions on this)for example:myclass.setTimeout( 250 );if( myclass.hasTimedOut() )...myclass.setRepeatingInterval( 100 );if( myclass.intervalHasElapsed() )... ... could be that hasTimedOut() and intervalHasElapsed() are internally identical.