Go Down

Topic: Help connecting to Bluetooth (Read 102 times) previous topic - next topic

gauteab

Hello. I am trying to connect my phone to a HC-05 Bluetooth module that's connected to my Arduino Uno. I have been able to send serial data to it and receive the correct feedback when sending AT commands, and the light on the module is blinking at 2 sec intervals, but I can not get to device to show up as available on my phone, or my friend's phone. Any idea what might be causing this?

The setup and code I'm using is currently the same as in this guide: http://www.instructables.com/id/Modify-The-HC-05-Bluetooth-Module-Defaults-Using-A/
 
, but I've been through a lot of different guides by now.

Any thoughts appreciated!

Nick_Pyner

#1
Dec 10, 2017, 02:58 pm Last Edit: Dec 10, 2017, 02:59 pm by Nick_Pyner
the light on the module is blinking at 2 sec intervals, but I can not get to device to show up as available on my phone
If the LED is blinking at that speed, that is the reason why it won't show up on the phone. When Bluetooth is in AT mode, it is not in communication mode. It cannot be in two modes at once, so start over with the LED flashing at 2Hz, which signifies "power on, ready to connect"

Most Instructables are junk, but that one specifically says it is for modifying the defaults, and Bitar does know what he is doing. I'm sure he has another article that addresses communications. You might find the following background notes useful

http://homepages.ihug.com.au/~npyner/Arduino/GUIDE_2BT.pdf
http://homepages.ihug.com.au/~npyner/Arduino/BT_2_WAY.ino
 

Go Up