Go Down

Topic: TFT 3.2 Touch Arduino MEGA Ghost Lines!!! (Read 4488 times) previous topic - next topic


Jan 19, 2013, 01:57 am Last Edit: Jan 19, 2013, 02:13 am by Nataly Reason: 1

I have bought a tft 3,2 touch screen from saintsmart


it include the shield for plug in it to the arduino Mega 2560,

I have downloaded all documentation, libraries, etc.

The problem is the following: when I run the example coming with the library, the screen seems to make interferece  and destroy the image on screen, appear bad lines, and looks really bad.

The libraries I have used to test the screen are: ITDB02_Graph16.h and the new version of this library, called UTFT.

I have recorded a video on youtube, and the example is loaded from library UTFT > UTFT_Demo_320x240. There you can see that the program runs correctly, but the image on screen is awful.

Here is the video of my screen working...


And here is the demostration video of the original screen of the manufacturer...


I thinks there is a big difference....

The white lines are statics.

I have do all I can do to solve the problem, looking for a solution on internet, etc. And I need to know if the screen is broken or can be repaired

Thanks in advance,

Nataly Lopez


Did you check your power supply ?
Is it instable ?
Is it within specs for both Arduino and displayshield ?
Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html


ITDB02_Graph16.h is redundant, just use UTFT

but this looks like a bad display, ask sainsmart for a replacement


My TFT 3.2 is showing some display problems as well. I'm trying to simply get two images to display alternately (each desired image is attached. A "Tower" and "Logo"). Usually the first two rounds work fine, but once the "Logo" appears a third time, I get a distorted image (example shown in the http://www.youtube.com/watch?v=6QjzpIKqI8k&feature=youtu.be). And when loading the images onto the TFT the screen gets all "crackly."
I am using an Arduino MEGA ADK with UTFT, UTFT_tinyFAT, and UTouch libraries. I've tried rewiring the apparatus and using a couple different power sources. What's weird is that when it was first connected it displayed just fine, but after a couple of days started becoming errant.
Anyone else ever experienced this or know what might be going on? Thanks.


yeah,i think so, this looks like a bad display, ask sainsmart for a replacement, thanks for your sharing


Hello, it may sound stupid, but did you remove the protective screen film that the screen comes with?
Else it's probably something wrong with the controller.
Tonto el que no entienda


Thanks for the replies. Removing the protective screen didn't do anything, and I tried using a second, new TFT screen that gave me the same headaches.

Go Up