Go Down

Topic: WiFi101 Firmware Updater says not latest version (Read 3801 times) previous topic - next topic

Aclassifier

Oct 15, 2017, 06:39 pm Last Edit: Oct 16, 2017, 01:48 pm by Aclassifier
Hi!

I have an Adafruit ATWINC1500 WiFi Breakout that I have connected to a Adafruit Feather ARM M0 basic proto board.

In short, the WiFi101 Firmware Updater says the newest firmware is 19.5.2 (By #define in the code, not by asking any server I presume) but Microchip [1] says it's 19.5.3 that is the newest.

This may be a question for Microchip whom I believe wrote the WiFi101 Firmware Updater, but since I am new to the Arduino IDE I probably have more questions about it. So I'll give it a try here and would be very happy if any of you would take the time to look throught this rather lengthy question. Because now I am stuck with not having the latest and greatest WiFi ATWINC1500 module.

How does the Arduino IDE let me deal with downloaded libraries? May I spawn a copy and try to redefine the WIFI_FIRMWARE_LATEST_MODEL_B "19.5.2" to "19.5.3"? Will it rebuild with that new source? Provided that were the solution.

I have "WiFi101 by Arduino Version 0.14.4 INSTALLED". This is what the Library Manager tells me is the newest.

Is it the WiFi101 Firmware Updater that contains the firmware binaries? If yes, then that explains why, in the Adafruit recipe [2], they say that "If you don't see the right/matching version you may need to update the IDE". I have 1.8.5.

I didn't dare to try anything with the libraries and the Updater, as I am afraid to have the WiFi board updated incorrectly. It updated correctly from 19.4.4 to 19.5.2 when I did it. I don't know how its boot loader behaves and how good it may be to fix wrongly updated versions.

Another matter is why the Updater talks about WINC1501 in its dropdown box, and not WINC1500.

I have blogged about all of this in a note [X]. It also shows how I have routed the pins.

UPDATE 16Oct2017
I saw in WiFi101 CHANGELOG that
WiFi101 0.14.0 - 2017.03.22
* Added support for firmware 19.5.2

and that the latest version was
WiFi101 0.14.3 - 2017.06.01
but that there was no sign of support for firmware 19.5.3
Do I then just lean back and wait until un update message arrives and do what I'm told?

[1] - http://ww1.microchip.com/downloads/en/DeviceDoc/Atmel_WINC1500_Software_Release_Notes.pdf

[2] - Updating Firmware

[X] - My Piggyback WiFi1500 sliceCARD. Disclaimer: The blog is just for fun, as a hobby. No money, gifts, ads etc. Also, I have no association with any of the manufacturers and vendors mentioned

sandeepmistry

Hi @Aclassifier,

We are integrating the newly release 19.5.4 firmware release in the following pull requests:



I don't think the 19.5.3 release was ever integrated into Atmel Studio, so we had no access to those binaries.

Go Up