Arduino Forum

Arduino Certified Products => Windows Virtual Shields for Arduino => Topic started by: well7come on Apr 28, 2016, 10:10 pm

Title: Ethernet Shield
Post by: well7come on Apr 28, 2016, 10:10 pm
hi,
please am have some problem with  Ethernet Shield, i want to use it to display temperature reading from DS18B20 sensor to a web page, first time i tried it work perfectly, if days later it stop working, i can it upload the sketch but there is no display on the serial monitor. i help to sort out what is going on.

thank
Title: Re: Ethernet Shield
Post by: mammutgp on Mar 10, 2018, 01:36 pm
Awesome
ساندویچ پانل (https://mammut-group.com)
Title: Re: Ethernet Shield
Post by: mammutgp on May 06, 2018, 09:25 am
Great Answer
دریافت بک لینک رایگان (http://blog.keepupseo.ir/free-backlink/)
Title: Re: Ethernet Shield
Post by: mmoarduino on Jun 14, 2018, 09:40 am
Hello,i'm french

I'm using Ethernet shields for UDP protocole with Ethernet lib,
my  problem is the write command is succesfull send my buffer after the Udp.endPacket(); but mac adresse of the shield Ethernet is send after the buffer like it is in the buffer to send.

WRITE CODE/
Udp.begin(localPort);
 Udp.beginPacket(broadcastIP, localPort);
 //Udp.println(Ethernet.localIP());
 Udp.write(datadetect_CI3100);
 Udp.endPacket();
 Udp.stop();

Where  datadetect_CI3100 is/
char datadetect_CI3100[]  = {
 0x30, 0x42, 0x36, 0x38, 0x44, 0x32, 0x32, 0x41, 0x54, 0x45, 0x4d, 0x49, 0x4c, 0x43, 0x53, 0x44, 0x4e, 0x41, 0x4c, 0x44, 0x45, 0x52, 0x30, 0x38, 0x30, 0x34, 0x33, 0x65, 0x39, 0x34, 0x34, 0x36, 0x33, 0x30, 0x63, 0x39, 0x62, 0x34, 0x38, 0x30, 0x34, 0x38, 0x30, 0x30, 0x30, 0x30, 0x30, 0x30, 0x01, 0x70, 0x72, 0x74, 0x01, 0x36, 0x30, 0x30, 0x30, 0x01, 0x63, 0x6d, 0x64, 0x01, 0x30, 0x01, 0x73, 0x69, 0x64, 0x01, 0x34, 0x31, 0x38, 0x30, 0x37, 0x2c, 0x37, 0x30, 0x32, 0x34, 0x35, 0x32, 0x36, 0x32, 0x01};

And shields mac adress is/
byte mac[] = {
 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };

So the view of the data in Wireshark are/
30 42 36 38 44 32 32 41 54 45 4d 49 4c 43 53 44 4e 41 4c 44 45 52 30 38 30 34 33 65 39 34 34 36 33 30 63 39 62 34 38 30 34 38 30 30 30 30 30 30 01 70 72 74 01 36 30 30 30 01 63 6d 64 01 30 01 73 69 64 01 34 31 38 30 37 2c 37 30 32 34 35 32 36 32 01 de ad be ef fe ed 01

In fact "de ad be ef fe ed 01" is send after the Packet !!! why and how can i do to not send this?
thanks
Title: Re: Ethernet Shield
Post by: pjrc on Sep 01, 2018, 02:46 am
Hello.  I'm one of the developers who maintains the Ethernet library....

Since this message was written, the Ethernet library has been updated to version 2.0.0.

In fact "de ad be ef fe ed 01" is send after the Packet !!! why and how can i do to not send this?
If this problem still happens with Ethernet 2.0.0, please create a bug report here:  (click the green "New issue" button)

https://github.com/arduino-libraries/Ethernet/issues (https://github.com/arduino-libraries/Ethernet/issues)

Please provide a complete program which I can copy & paste into Arduino and upload to a board to recreate the wrong UDP packet problem.  Please also mention which board and shield you are using.  I can only investigate this problem if I receive a bug report on the issue tracker with enough clear info to recreate the problem.