Go Down

Topic: Uno R3 ATMega328P avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp= (Read 1 time) previous topic - next topic

Dnox

Hi Guys!

I have an Arduino Uno R3 board, I'm using version 1.6.5 software for windows, and even after installing drivers when I run the script the following message appears:

avrdude: stk500_getsync () attempt 10 of 10: not in sync: resp = 0xAF

Can someone tell me, please!

Thanks

Dnox

Hi guys!

I solved this problem downloading the chip controller driver in this chinese site http://www.wch.cn/download/CH341SER_EXE.html

I hope to help those who are also with this problem by using the Arduino Uno R3 with Atmel 328p

Good Luck!

Marmotjr

Ok, since the site is completely in chinese, I am very hesitant to download.

I hadn't touched my UNO in a few months, been mainly playing with nano's.   Went to upload some code the other day, got a similar error  (avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x07).   Shortly after, my nano's stopped uploading (win7).  Went and upgraded to 1.6.5 IDE, and it fixed the nano issue. 

Still getting the same error on the Uno though.   It's recognized as an Uno on Com5 (it's always been on com5), the power light is on, and led on 13 is on.   When uploading, every 10 seconds or so the Rx light blinks once. 

All code, including the blink example, no wires attached, has the same result.  I have tried other 328's on the board too, as I was planning to use the Uno to program some chips.   Any suggestions?

liuzengqiang

Hi guys!

I solved this problem downloading the chip controller driver in this chinese site http://www.wch.cn/download/CH341SER_EXE.html

I hope to help those who are also with this problem by using the Arduino Uno R3 with Atmel 328p

Good Luck!
What you have is not exactly Arduino UNO R3, but a compatible board with different chip on the board. The chip is CH340 or CH341. If you have the original UNO then the driver is already in the arduino software.
Serial LCD keypad panel,phi_prompt user interface library,SDI-12 USB Adapter

liuzengqiang

Ok, since the site is completely in chinese, I am very hesitant to download.

I hadn't touched my UNO in a few months, been mainly playing with nano's.   Went to upload some code the other day, got a similar error  (avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x07).   Shortly after, my nano's stopped uploading (win7).  Went and upgraded to 1.6.5 IDE, and it fixed the nano issue.  

Still getting the same error on the Uno though.   It's recognized as an Uno on Com5 (it's always been on com5), the power light is on, and led on 13 is on.   When uploading, every 10 seconds or so the Rx light blinks once.  

All code, including the blink example, no wires attached, has the same result.  I have tried other 328's on the board too, as I was planning to use the Uno to program some chips.   Any suggestions?
You have a different question. You're using win7, so go to device manager and find the port device with com5. Select properties and view the Details tab. Select under Property "Hardware Ids". Report back the value you see.

The Chinese site is ligit. You may have their chip or you may not. The answer is in your computer.
Serial LCD keypad panel,phi_prompt user interface library,SDI-12 USB Adapter

Marmotjr

Will do Liudr, was just hesitant to access anything there, given the thread had no replies and the poster was new...

Hardware ID:

USB\VID_2341&PID_0043&REV_0001
USB\VID_2341&PID_0043

liuzengqiang

OK so you have the arduino official (or knockoff) UNO R3 using ATMEGA16U2 chip. The driver is under arduino ide's drivers folder. Go to the unknown device and choose update driver and browse, point to that driver folder and you're golden.
Serial LCD keypad panel,phi_prompt user interface library,SDI-12 USB Adapter

Marmotjr

Its already recognizing it as an Uno, but I still tried to update the driver, said it's current.

Tried uploading Blink again, new error msg this time:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x9b


liuzengqiang

OK then it's not the driver issue. Do you have anything connected to the board? If yes, remove it. You could have a broken ATMEGA328 chip (the long chip) on the board. Do you have any spare ATMEGA328 chips with bootloader?
Serial LCD keypad panel,phi_prompt user interface library,SDI-12 USB Adapter

Marmotjr

Nothings attached, hence why I was trying Blink.  I have already removed the chip, replaced it with another (that supposedly has the bootloader already on it), and had similar results.   I'll try again with a third chip (from the same lot as the second). 

I was hoping to use the UNO as a programmer for these chips....

septillion

Can you try on another computer?

If you're really out of luck the program in the ATMEGA16U2 is corrupt and you have to flash it again. But then you need a programmer or another Arduino as ArduinoISP.
Use fricking code tags!!!!
I want x => I would like x, I need help => I would like help, Need fast => Go and pay someone to do the job...

NEW Library to make fading leds a piece of cake
https://github.com/septillion-git/FadeLed

Marmotjr

Still no joy....

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xe8


Back to the original chip to see if the resp code changed back:  (dunno if that helps or not)

Different error message, same result though...

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x78


Marmotjr

I'll give another machine a shot later in the day.

Thank you for the help guys!!

charlifumi

I do experience the same issue - I tried to power on/power off, upgrade from several computers (Win7, Win10 and MacOS) and It's consistent. BTW, my UNO is well connected as the software uploaded previsouly is still working fine.
I'm using the latest image 1.6.5. Any idea ?

Dnox

Thanks liurd,

But i did not know this board is not original.

About the chinese site is very safe.

Grateful

Go Up