Go Down

Topic: IDE 1.8.0 Released -- update: 1.8.4 (Read 37643 times) previous topic - next topic

NXTwoThou

#120
Aug 30, 2017, 04:39 pm Last Edit: Aug 30, 2017, 09:24 pm by NXTwoThou
I'm having a similar issue.  Windows Store updated to 1.8.7.0 yesterday(1.8.4 IDE) and haven't been able to get anything to compile since for my Due.   After updating, it no longer had my particular sketch loaded, which wasn't a big deal.  Then it asked me to update Arduino SAM Boards to 1.6.11 which it did without issue.  I selected my sketch, selected my board and port, then got a compile error of "arm-none-eabi-g++: error: CreateProcess: No such file or directory"

I turned on verbose output and it's pointing to "C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\".   If I switch to something like the Mega, it's pointing to the proper folders of "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware" and can compile just fine.

I tried going back to 1.6.10 and get the same thing. 

Preferences show "more preferences can be edited directly" and points to c:\users\nxtwothou\AppData\Local\Arduino15\preferences.txt which doesn't exist.  It's located in C:\Users\nxtwo\AppData\Local\Packages\ArduinoLLC.ArduinoIDE_mdqgnx93n4wtt\LocalCache\Local\Arduino15 and C:\Users\nxtwo\Documents\ArduinoData (which is old)
and C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\lib (which is even older)

Suggestions welcome on how to fix the upgrade mess(or better yet, releasing another upgrade to correct the issue before too many others experience it too).

Update:  I completely uninstalled, cleared my temp folder and everywhere else that was *arduino* on my machine. Then reinstalled.  I then installed the 1.6.11 of SAM and selected the Due with the default empty sketch.  Got the same errors, so turned on verbose and so, here we go, right out of the box from the Windows Store:
Code: [Select]

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware -hardware C:\Users\nxtwo\AppData\Local\Arduino15\packages -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware\tools\avr -tools C:\Users\nxtwo\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\libraries -libraries C:\Users\nxtwo\Documents\Arduino\libraries -fqbn=arduino:sam:arduino_due_x_dbg -ide-version=10804 -build-path C:\Users\nxtwo\AppData\Local\Temp\arduino_build_87505 -warnings=all -build-cache C:\Users\nxtwo\AppData\Local\Temp\arduino_cache_873775 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose C:\Users\nxtwo\AppData\Local\Temp\untitled2102902874.tmp\sketch_aug30a\sketch_aug30a.ino
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\arduino-builder -compile -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware -hardware C:\Users\nxtwo\AppData\Local\Arduino15\packages -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware\tools\avr -tools C:\Users\nxtwo\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\libraries -libraries C:\Users\nxtwo\Documents\Arduino\libraries -fqbn=arduino:sam:arduino_due_x_dbg -ide-version=10804 -build-path C:\Users\nxtwo\AppData\Local\Temp\arduino_build_87505 -warnings=all -build-cache C:\Users\nxtwo\AppData\Local\Temp\arduino_cache_873775 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose C:\Users\nxtwo\AppData\Local\Temp\untitled2102902874.tmp\sketch_aug30a\sketch_aug30a.ino
Using board 'arduino_due_x_dbg' from platform in folder: C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11
Using core 'arduino' from platform in folder: C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11
Detecting libraries used...
"C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10804 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "C:\Users\nxtwo\AppData\Local\Temp\arduino_build_87505\sketch\sketch_aug30a.ino.cpp" -o "nul"
Generating function prototypes...
"C:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10804 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IC:\Users\nxtwo\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "C:\Users\nxtwo\AppData\Local\Temp\arduino_build_87505\sketch\sketch_aug30a.ino.cpp" -o "C:\Users\nxtwo\AppData\Local\Temp\arduino_build_87505\preproc\ctags_target_for_gcc_minus_e.cpp"
arm-none-eabi-g++: error: CreateProcess: No such file or directory

exit status 1
Error compiling for board Arduino Due (Programming Port).


Note, C:\Users\nxtwo\AppData\Local\Packages\ArduinoLLC.ArduinoIDE_mdqgnx93n4wtt\LocalCache\Local\Arduino15\packages\arduino\hardware\sam\1.6.11 is where the actual files were downloaded to with the update.

pert

Update:  I completely uninstalled, cleared my temp folder and everywhere else that was *arduino* on my machine.
Did you also delete C:\Users\nxtwo\AppData\Local\Packages\ArduinoLLC.ArduinoIDE_mdqgnx93n4wtt?

Typically this sort of problem happens when something goes wrong with the Boards Manager hardware package installation.

DMSM

#122
Aug 31, 2017, 09:48 am Last Edit: Aug 31, 2017, 10:03 am by DMSM
Did you also delete C:\Users\nxtwo\AppData\Local\Packages\ArduinoLLC.ArduinoIDE_mdqgnx93n4wtt
C:\Users\mahmo\AppData\Local\Packages\ArduinoLLC.ArduinoIDE_mdqgnx93n4wtt Doesn't exist for me...

About the AppData folder itself, I cannot see the folder it without a writing the direct path in file explorer. Also when opening it up, it is empty.

However this may just be me, since I have had to remove some malware/adware recently (I went into clean boot to clear temp files and ran malwarebytes). Most of it was removed but google chrome still had some issues. I went digging down into registries, and it seemed like malware bytes left out some stuff.

I googled my issues, and usually corrupted registries lead to a corrupted AppData folder.

Anyways I am planning to rebuild my computer and start on a fresh copy of windows soon. Sorry if this wasn't as helpful.

pert

The bug with the Windows Store version of the Arduino IDE has now been fixed:
https://github.com/arduino/Arduino/issues/6673
but will take a couple of days before it is released to the app store. In the meantime you are welcome to use the standard installation of the Arduino IDE downloaded from http://www.arduino.cc/en/Main/Software, which does not have this bug.

DMSM

In the meantime you are welcome to use the standard installation of the Arduino IDE downloaded from http://www.arduino.cc/en/Main/Software, which does not have this bug.
I was using the one from the website, I have tried to downgrade to 1.8.2, but that didn't make a difference.

pert

I was using the one from the website, I have tried to downgrade to 1.8.2, but that didn't make a difference.
Please try this:
  • Rename C:\Users\mahmo\AppData\Local\Arduino15 to C:\Users\mahmo\AppData\Local\Arduino15.bak
  • Restart the Arduino IDE
  • Tools > Board > Boards Manager
  • Wait for downloads to finish
  • Click on "Arduino SAMD Boards"
  • Click "Install"
  • Wait for installation to finish.
  • Click "Close"
  • Tools > Board > MKR1000
  • Sketch > Verify/Compile

chibiconsulting

#126
Aug 31, 2017, 11:19 pm Last Edit: Sep 01, 2017, 02:11 am by chibiconsulting
Just had a Widowz issue. Steps above work.

pert

Preferences show "more preferences can be edited directly" and points to c:\users\nxtwothou\AppData\Local\Arduino15\preferences.txt which doesn't exist.  It's located in C:\Users\nxtwo\AppData\Local\Packages\ArduinoLLC.ArduinoIDE_mdqgnx93n4wtt\LocalCache\Local\Arduino15 and C:\Users\nxtwo\Documents\ArduinoData (which is old)
and C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\lib (which is even older)
@NXTwoThou, please report this bug (incorrect preferences.txt location shown in File > Preferences when using Windows Store version) to the Arduino developers here:
https://github.com/arduino/Arduino/issues/new
I would do so myself but I only report bugs I can personally reproduce and I don't use Windows 10 so I can't use the Windows Store version of the Arduino IDE. Thanks!

pert

Just had a Widowz issue. Steps above work.
Glad to hear! You are free to delete the Arduino15.bak folder you created. The only reason for doing that was to keep a backup of that folder in case you wanted to revert to the previous state. If things are working well with the new installation you don't need it or if you wanted to restore your previous preferences you can copy over the preferences.txt file with the IDE not running.

pert

#129
Sep 11, 2017, 04:48 pm Last Edit: Sep 11, 2017, 11:16 pm by pert
There is a small bug with Arduino IDE 1.8.4. A keyboard shortcut was added in this version that allows you to change the editor font size via ctrl+mouse wheel. Unfortunately the code doesn't prevent you from shrinking the font size all the way down to 0 or a negative number. If you exit the Arduino IDE with the font set to 0 or less you will not be able to start it again, you just get the splash screen and then nothing. If you check the console output during process (arduino_debug.exe for Windows users) you will see the error:

Code: [Select]
java.lang.IllegalArgumentException: Font size must be > 0

If this happens you can fix it by:
  • Open preferences.txt in a text editor.
  • Change the number at the end of the editor.font property setting to something greater than 0.
  • Save the file.

OR:
  • Download the hourly build: http://www.arduino.cc/en/Main/Software#hourly
  • Run the hourly build (the bug has been fixed in the hourly so it will start).
  • Use ctrl+mouse wheel to change the font size to a size greater than 0.
  • File > Quit
  • You can now remove the hourly build and go back to using 1.8.4 again.


I'm not sure what possesses people to shrink the font size down to invisibility but it's been reported quite frequently since the release of 1.8.4 so I thought it worth adding a note to this thread.

Please DO NOT report this on the GitHub issue tracker. The bug has already been fixed and the issue has been reported about 7 times again since the fix. https://github.com/arduino/Arduino/issues/6689

MAS3

Still a good thing to mention it in this thread, pert.
This is where a user might look, not in the developer's Github whatchamacallit.

Thanks !
Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Go Up