Go Down

Topic: ADS1115 to read Vacuum Sensor (Read 582 times) previous topic - next topic

AngeloGomes

Hi guys. I need some help, as my electronics skills are basic.

Well, I had a Cold cathod gauge from adixen with the appropriate gauge controller. Some days ago the gauge controller failed to detect which sensor is connected to it. I decided to use the arduino to read the voltage from the gauge and convert it to pressure following the equation released with the manual. In order to get the voltage from the gauge, I used a ADS1115 from adafruit. However, I still use the gauge controller to supply the 24V to the sensor electronics. From the sensor, I have two pins where I have 0-10V as  response.  The gauge manual says it has an impedance of 200 ohms on these pins.

As the  gauge response is 0-10V and the ADS1115 only senses up to 6.1V I've made a voltage divider using 2 resistors of the same value.

From this point, without connecting the wires to the ADS1115, using 1kohm resistors, with a multimeter I measured 4.1V, in the divider,  which is the half of the voltage between the two pins (8.2 V). So the voltage divider is OK.

Now comes the difficult part to me, which is to connect the divider to the ads1115. If I put the (-) from the gauge to the ground on ads1115 and the middle leg of the divider in one channel of the ADS1115, I never get the 4.1V, but extremely low voltages instead.

I suppose it is something related to grounds, but I am not sure about this.

I have connected GND of ADS1115 ito GND from arduino.


Should I connect those grounds to the ground of the PS supply of the gauge controller ?



















AngeloGomes

Manual:



https://www.ajvs.com/library/ADIXEN%20ACS%202000%20GAUGE%20CONTROLLER.pdf

wvmarle

Make sure the connections to your ADS1115 are good.

What voltage do you measure AT THE PIN of the ADS1115?
Quality of answers is related to the quality of questions. Good questions will get good answers. Useless answers are a sign of a poor question.

pito

Read the ADS1115 datasheet carefully.
The max input voltages are not those you mention in your post.


MarkT

You certainly can't measure 6.1V with a 5V part. You can blow up the 5V part however...  1k resistor
is probably enough to prevent this, fortunately.

Use much higher divider resistors so you don't load the guage much, perhaps 100k and 68k (0.1%) which
maps 10V to 4.047V which is within the 4.096V range.  A 200 ohm device driving 168k will see about 0.1%
droop, which you can live with.  200 ohm driving 2k will have 10% droop and will probably go non-linear
due to overload.

Add a 10nF capacitor on the input pin to reduce noise and provide a low impedance to the ADC.

Learn to drive the ADC with a known test voltage first, only then start connecting the real hardware -
always progress in small steps in a big project, otherwise its so easy to get stuck/confused.
[ I will NOT respond to personal messages, I WILL delete them, use the forum please ]

Go Up