Go Down

Topic: IDE 1.8.0 Released -- update: 1.8.5 (Read 60741 times) previous topic - next topic

pjrc

For anyone seeing the font problem, there's now a fix on Github.

https://github.com/arduino/Arduino/pull/5756

ballscrewbob

Thanks Paul.

On one monitor it looks fine but my other monitor it looks faint That fixed it.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

DaveAhrendt

#17
Dec 24, 2016, 07:27 pm Last Edit: Dec 24, 2016, 10:44 pm by DaveAhrendt
1.8.1 fixes both the menu font display and the code editor display

Followup that the patch from github works fine on my Win10 64 bit system but just hangs on Win10 32 bit.

bperrybap

I noticed that the in the file hardware/arduino/avr/platform.txt file, it says the IDE is version 1.6.16 instead of version 1.8.0
See line 9 of the file.

This is also true in the pre-release 1.8.1 images in the 5756 linked above.

--- bill

bperrybap

Does this mark the end of the Arduino vs Arduino days?

Anyone played with it? Does it break stuff?
The linux 32 bit 1.8.0 package from arduino.cc is not the same as the 1.8.0 package from arduino.org

The arduino.org IDE is missing the java directory and arduino-core.jar and pde.jar are different in the two packages.

The IDE 1.8.0 from arduino.cc seems to work ok on 32 bit linux Mint 17.1 but IDE 1.8.0 from arduino.org does not. The arduino.org IDE immediately crashes.


--- bill

oqibidipo

I noticed that the in the file hardware/arduino/avr/platform.txt file, it says the IDE is version 1.6.16 instead of version 1.8.0
That is not IDE version, but AVR boards version.

pert

The linux 32 bit 1.8.0 package from arduino.cc is not the same as the 1.8.0 package from arduino.org
Well that's sure annoying. I've been hoping that with the reconciliation things would get less fragmented but having two different IDEs with the same version number is actually worse. You'd think they'd just distribute the same exact file from the same server. A quick test of the arduino.org 1.8.0 Windows build seems to work but a diff shows they are definitely different. What a completely idiotic thing to do!

bperrybap

That is not IDE version, but AVR boards version.
I see. and I now see that it never really was tracking the IDE release version.

pjrc

I just did a compare between Arduino.cc and Arduino.org's pde.jar and arduino-core.jar files (the two files that really implement the Arduino IDE).

While the jar files differ on a binary compare, if you extract them and compare their contents, all of the .class files within are a perfect binary match.  The only difference is the META-INF/MANIFEST.MF files.

Arduino.cc is compiling with:

Ant-Version: Apache Ant 1.9.4
Created-By: 1.8.0_111-b14 (Oracle Corporation)


Arduino.org is compiling with:

Ant-Version: Apache Ant 1.9.7
Created-By: 1.8.0_112-b15 (Oracle Corporation)


They both compiled exactly the same code and produced exactly the same JAVA bytecode.  One of them had just a slightly newer version of the JDK toolchain installed on their build machine.

Lots of other files are different, but again is appears to be mostly related to Arduino.cc shipping java runtime 8.0.111 b14 and Arduino.org shipping java runtime 8.0.112 b15.

The main exe launcher is also different.  I didn't dig into this, but since it doesn't do much, my guess is they've both signing it with their own code signing cert.

It's easy to leap to conclusions and assume the worst.  But if you look at what's actually different, I'd say there's not much to see here.  They both built from the same exact source, but used slightly different versions of Java to do their builds.

pert

There's a huge size difference between the two, both Linux and Windows releases. Even if they do both work it's just insane to have two different version of a release. A version number should mean something, that's such a basic concept it just astounds me that it's not obvious to these guys. I should get an identical checksum regardless of where the IDE was downloaded from. This makes providing support more difficult. Now when someone comes here with a problem I can't reproduce I have to find out which site they downloaded their IDE from:
"I got it from the Arduino website"
"Which Arduino website?"
"Huh, there are multiple Arduino websites WTF?"
"It's a long story..."

bperrybap

The difference between the two Linux 32 but is what I said earlier. There is a missing java directory and then the two jar files. Everything else is the same.

bob_kuhn

I've installed 1.8.0 on a Mac with Sierra OS;.upgrading from 1.6.13.  Tested a few complex programs using serial, i2c and spi for the ATmega328P and  ATmega1284P.  No problems, so far.
What IDE extension did you use to compile the 1284?

THOR-00

#27
Dec 26, 2016, 11:33 am Last Edit: Dec 26, 2016, 11:42 am by THOR-00
When the windows store app update comes?
... and dark mode? :P

pert

When the windows store app update comes?
Is it still all the way back at 1.6.11?

mglass

#29
Dec 27, 2016, 01:20 am Last Edit: Dec 27, 2016, 01:56 am by mglass
I've installed arduino 1.8 (exe) on Windows 7, but I can't get access to the Ports sub-menu. I have an Arduino M0 Pro installed and the USB connection verifies that (it says under Device Manager, USB Devices: Arduino M0 Pro), but it doesn't have a COM number. Please advise.

Go Up