Go Down

Topic: GSM v2 sending SMS but not receiving  (Read 290 times) previous topic - next topic

Lubby

I have a GSM shield, version 2 with M10AF-03-STD modem on it.

I have managed to get it to send out a text but can not get it to receive a message.
I have set the band to 850 and PCS1900.
If I put in the PIN number it will not connect but does when one is not entered.

As mentioned an outgoing text with the GSM Example code will work.

When running the GSM Example Code for ReceiveSMS I get the following:

SMS Messages Receiver
GSM initialized
Waiting for messages
Message received from:
18
Voice     Msg notice Total: 1 (0 urg.)
END OF MESSAGE
MESSAGE DELETED

I get this in the serial port as soon as it is initialized - only I have not sent a voice message.  When I do send a text to the SIM nothing happens.

Any suggestions on where to check next?

Lubby

Problem Solved.

I swapped in a SIM from a different phone and everything worked fine?  Same SIM provider, although one is newer than the other.

The GSM version 2 might need a SIM that is less than 2 years old.


Go Up