Go Down

Topic: Uploading error: Cannot open DFU device 8087:0aba on PC [PARTLY SOLVED USB 3] (Read 13023 times) previous topic - next topic

rz2222

I tried today the new version of dfu-uitl as instructed in the thread http://forum.arduino.cc/index.php?topic=388754.0  and ... bingo! It works.

SVGEST

I had post a reply message that on my computer it did not work but it seems that the messege is removed .... !?

So on my computer the new driver did not solved the problem.

LocalgHost

 Solved for me by  manually installing USB drivers from :

C:\Users\dekoc\AppData\Local\arduino15\packages\Intel\tools\arduino101load\1.6.4+1.18\drivers\
using dpinst-amd64.exe

Win 10, and using USB2.0 and USB3.0 ports

then uploads worked correctly
.
  .
...

SVGEST

I have tried to do the same,

but it still does not work on my computer (Windows 7 64bit), not on USB2.0 not on USB3.0  >:( .


garett0439

Does not work (cannot open DFU device 8087: 0aba) on my laptop with windows 10, which only has usb 2.0 ports. Works on my dekstop with windows 7.

This is really disappointing since this problem has been unsolved for months. I am using arduino  1.6.9

famus

Wow. I had the same problem on Win 7. I followed suggestion to use USB3.0 on the PC. It worked!

I didn't even have the libusb device installed, only the Arduino 101 Serial Monitor (COM3).

Rohan621

Hi Guys,

So, I was facing the same problem. However, after reading a lot of posts from this forum, I connected the Arduino 101 to the USB 3.0 port of my Laptop. Its the port with a blue printed SS and USB symbol.

This solved the DFU problem for me.

Also, if it says that the error regarding not able to find arduino101load. Go to

https://github.com/facchinm/arduino101load/tree/master/bin/windows (Only for windows users.). Download the arduino101load.exe file in the arduino101load folder in C:\Users\<username>\AppData\Local\Arduino15\packages\Intel\tools\arduino101load\1.6.4+1.18\arduino101load

Note: AppData folder is a hidden folder. So, select the option "Show hidden folders" in the folder menu.

Feel free to ask any questions


StephaneBadts

Something new with this? I have the same problem.... Thanks guys.

facchinm

We just published core 1.0.7 with updated dfu procedure, please test it and report the results, thanks!

SVGEST

I have updated my boards as the IDE,  so I'm working with arduino ide 1.6.12 and the intel curie board ver 1.0.7.  but nothing have changed, I still have the same error :

Arduino: 1.6.12 (Windows 7), Board:"Arduino/Genuino 101"

Build-opties gewijzigd, alles wordt opnieuw gebuild

De schets gebruikt 17.628 bytes (11%)  programma-opslagruimte. Maximum is 155.648 bytes.
Een reset wordt geforceerd (met 1200bps openen/sluiten) op poort COM8
C:\Users\Staf\AppData\Local\Arduino15\packages\Intel\tools\arduino101load\1.6.9+1.28/arduino101load/arduino101load C:\Users\Staf\AppData\Local\Arduino15\packages\Intel\tools\arduino101load\1.6.9+1.28/x86/bin C:\Users\Staf\AppData\Local\Temp\arduino_build_278052/Blink.ino.bin COM8 verbose ATP1BLE000-1541C5635 141312
Starting download script...
Args to shell: [C:\Users\Staf\AppData\Local\Arduino15\packages\Intel\tools\arduino101load\1.6.9+1.28/x86/bin C:\Users\Staf\AppData\Local\Temp\arduino_build_278052/Blink.ino.bin COM8 verbose ATP1BLE000-1541C5635 141312]
Serial Port: COM8
BIN FILE C:\Users\Staf\AppData\Local\Temp\arduino_build_278052/Blink.ino.bin
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
Flashing is taking longer than expected
Try pressing MASTER_RESET button
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
ERROR: Timed out waiting for Arduino 101 on COM8
ERROR: Timed out waiting for Arduino 101 on COM8

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.



and the same thing is happening in the hardware configuration screen;

I see the Arduino 101 Serial Monitor 5COM8) under 'ports (COM & LPT)
but when the upload of the program starts, this disappears and 'GENUINO 101' appears under 'other devices' for a second or so. Then it reappears under ports BEFORE the upload of the programs ends in the time out error.




facchinm

Hi SVGEST,

if you continue clicking, maybe once per second, the MASTER_RESET button, does the board eventually gets recognized as "Arduino101 DFU" ? I believe that the driver installation is unable to complete before the board becomes operative again, so you need to force it staying in DFU mode until the driver catches up

SVGEST

If I start clicking on the MASTER RESET key, it doesn't get recognized as Arduino101DFU.


ballscrewbob

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

SVGEST

I have installed the new core 1.07, but I still can't upload anything to my 101 !

If I run dfu-util -l I don't see any device in the list...

So what is the reason that I see an 'arduino 101 serial monitor' in my device management window and not a dfu-device ?

Go Up