Go Down

Topic: Arduino 101: Installing 'Intel Curie Boards' does not install Curie libraries (Read 5137 times) previous topic - next topic

kensu

Hello,

I bought the Arduino 101 and installed the Intel Curie Boards core as advised on the Quick Start Tutorial (https://www.arduino.cc/en/Guide/Arduino101). However, unlike what is suggest in the tutorial, the CurieBLE, CurieRTC and CurieIMU libraries were not automatically installed.

Instead, I downloaded them manually from GitHub (https://github.com/01org/corelibs-arduino101) but encountered many problems running even the simplest of the examples (CurieBLE->LED). I get a lot of errors for the include paths in multiple files, and a warning stating that the CurieBLE library is supposed to be executed on a ARC32 architecture but my card only runs AVR (I have set the card to arduino101, and the driver works fine).

My questions are: did anyone have the Intel curie libraries installed automatically? and if not, did you get the same problems with the github libraries!

Thanks a lot.

Oh yeah, I am using the IDE 1.6.7

Cheers.

pert

CurieRTC was renamed to CurieTime but the tutorial was never updated to reflect the change. My installation contains all 3 of those libraries. What makes you think they were not automatically installed? I just compiled File > Exampes > CurieBLE > LED with no errors. Are you using Arduino IDE 1.6.7?

Edit: oops, I see you already stated you're using 1.6.7.

kensu

Hello,

Thanks for your reply.
I got the error "CurieBLE.h" missing. I've been looking for these libraries and found them nowhere. In your case, they were installed automatically when you installed the Intel Curie Boards core? Where were they installed?

Thanks!

pert

In your case, they were installed automatically when you installed the Intel Curie Boards core? Where were they installed?
Yes, they were installed automatically when I installed the Tools > Board > Boards Manager > Intel Curie Boards > Install. If you select Tools > Board > Arduino 101 and then do File > Examples do you see CurieBLE, CurieIMU and CurieTime on the list? They are installed at C:\Users\per\AppData\Local\Arduino15\packages\Intel\hardware\arc32\1.0.4\libraries on my system(Windows), the Arduino15 folder is where the Boards Manager installs boards packages, it's different on other OSs but you can get to that folder by File > Preferences > More preferences can be edited directly in the file on any OS.

kensu

Thanks a lot! You are right they were in the folder you mentioned, I didn't look carefully.

But the examples do not appear directly on the Arduino IDE File>Examples. If I add the library  Sketch>Include Library>Add .Zip Library it is copied to Documents/Arduino/Libraries and the examples appear.
I added CurieBLE and tried the LED example again, but I still get the same errors I got when I downloaded the libraries directly from github:
C:\Users\enk\Documents\Arduino\libraries\CurieBle\src/BLECommon.h:25:46: fatal error: ../src/services/ble/ble_protocol.h: No such file or directory

The includes in BLECommon.h are:

#include "../src/services/ble/ble_protocol.h"
#include "services/ble/ble_service_gatt.h"
#include "services/ble/ble_service_gatts_api.h"

These are relative paths starting from C:\Users\enk\AppData\Local\Arduino15\packages\Intel\hardware\arc32\1.0.4\system\libarc32_arduino101\framework\include

Sooo... I'm thinking that I am probably unable to include libraries correctly using the Arduino IDE. What do you think?

Thanks a lot for your help.


pert


kensu

Yes I do. And I'm using the programmer AVRISP mkII.

pert

Well all I can say is it works for me even when I copy the CurieBLE library to my sketchbook\libraries folder as you have it. I would recommend you to click the Report to moderator button on your post and request that this thread be moved to the Arduino 101 section of the forum. Hopefully someone with more experience with the 101 will see it there and be able to help you.


drmpf

My problem is a little different.
Was running 1.6.7 on Arduino 101, 
Tried updating to Curie 1.0.5  but USB driver did not install and could not program the 101
Downloaded 1.6.8 IDE in zip and installed to its own dir.
Removed Curie 1.0.5 and reinstalled  (with 101 board not plugged in)
Started IDE 1.6.8
plugged 101 in and USB driver installed
opened Curie  CallbackLED example and compiled and uploaded OK
Opened my sketch and compile fails with

CurieBle.h: No such file or directory

This sketch which used to compile under 1.6.7 now no longer compiles under either 1.6.7 or 1.6.8

Any suggestions on how to fix the include paths?

drmpf

Tried removing the preferences.txt file and having it recreated.
Reinstalled Curie 1.0.5
plugging in 101 and USB drive installed
but
now the CallbackLED example will not upload.

drmpf

Updated the dfu_utils as per the sticky thread.
Now can upload the example but only if I press the master reset before starting the upload

Still have this error
fatal error: CurieBle.h: No such file or directory

for my sketch which was compiling and uploading with 1.6.7 and now does not.

drmpf

Tried putting my sketch in CurieBLE examples folder.  Still failed to find CurieBle.h
so I copied and pasted the include line from the CallbackLED example and replaced my include code with it.
Then it compiled
and still compiled when moved back to normal Arduino dir.

So I can only conclude there where some 'bad' and not visible chars in the sketch file on the include line.

facchinm

Hi drmpf, from 1.0.5 the BLE library is called CurieBLE (capital BLE).
We changed this because CurieBle (1.0.4) and CurieBLE (1.0.5) are not API-compatible since now the library is in sync with sandeep's BLEPeripheral (https://github.com/sandeepmistry/arduino-BLEPeripheral)

drmpf

Thanks missed that case change.  That explains it. 
BTW  uploads now run without needing the reset
so all good. 

Go Up