track counter

they are same

// Variables will change:
int trackNumber = 0;
int TrackCounter = 0;

What do you mean by "they are same" ? From those two lines we can only see they've got the same initialization value. Do you expect that changing one will automatically change the other ?

Also, why do you use first capital letter in one case and not in the other ? Don't overlook these small details, or you'll be facing hard-to-solve bugs, especially in long code.
What's worse, you have to semantically interchangeable variables, that are easily confused. If you really need them both, give them a more descriptive name (*).
One last thing... comments like "variables will change" are of little help. Perhaps you could write a description of each variable role in the code, instead. :stuck_out_tongue:

Just my 2 cents.

:slight_smile: