problem rc receiver signal

I changed the numbers so we would quit misreading 14335/14535

Actually, this is a perfect illustration of why magic numbers are a bad idea.

#define LOW_VAL 14335
#define HIGH_VAL 14535

if(val < LOW_VAL)
{
}
else if(val > HIGH_VAL)
{
}
else
{
}

means you correct an error/erroneous value in one place, and the logic is far easier to see.