Go Down

Topic: No LuCI web interface [SOLVED] (Read 243 times) previous topic - next topic

hankk

May 08, 2018, 09:52 pm Last Edit: May 11, 2018, 08:05 am by hankk
After setup php and MySQL  i have  index of directory /www instead LuCI web interface ?


Quote
Index of /
../
modified: Mon, 07 May 2018 21:43:53 GMT
directory - 1.00 kbyte

cgi-bin/
modified: Tue, 08 Jul 2014 13:06:33 GMT
directory - 0.03 kbyte

keystore_manager_example/
modified: Tue, 08 Jul 2014 13:06:58 GMT
directory - 0.05 kbyte

luci-static/
modified: Tue, 08 Jul 2014 13:05:31 GMT
directory - 0.07 kbyte

omoc/
modified: Tue, 08 May 2018 18:30:58 GMT
directory - 1.00 kbyte

sd/
modified: Mon, 07 May 2018 18:46:56 GMT
directory - 8.00 kbyte

index.html
modified: Tue, 18 Feb 2014 10:43:40 GMT
text/html - 0.43 kbyte

phpinfo.php
modified: Mon, 07 May 2018 20:31:24 GMT

dualcei

When configuring the default web server (uHTTPd) to use PHP you probably change the root www folder or other uHTTPd configuration. The LuCI web interface is a CGI web application thats runs over the same uHTTPd web server instance at port 80.

If was this, the best way do fix it is reset all the board pushing the "Reset WiFi button" (button near the USB connector) for more than 30 seconds - if you do this, the Arduino will be reset to all original factory configurations and software packages (ALERT: this procedure may be delete all local files). See Arduino Yun Getting Started to detailed instructions (https://www.arduino.cc/en/Guide/ArduinoYunLin)

Good luck ;-)

hankk

I was looking for a solution outside the reset to the factory settings, as there was no answer I did this reset and now it works

Go Up