Go Down

Topic: Getting Started Trouble (Read 1 time) previous topic - next topic


I've been trying to install my Uno SMD on XP Home for days.  Today I'm documenting in hopes that I can help someone, or get help if needed.

When I first received my board, I mistakingly followed the getting started link from arduino.cc first.  This told me to NOT select the drivers/FTDI USB Drivers directory.  I have tried on XP Pro and XP Home and have failed after troubleshooting for days.

Today I found that by launching the software (Arduino Alpha 0022) Help > Getting Started, it instructs me to first select drivers/FTDI USB Drivers directory, then repeat.  The first time will give me "USB Serial Converter" found, then the second time "USB Serial Port" will be found.  I just tried that procedure and it seems I'm still not able to install, though the errors are a bit different.

Here is my next run,
1. I went to Device Manager >
2. Go to Start > Control Panel > Add Hardware
3. Click Next
4. Select No, not this Time.  Click Next
5. Select Install from a list or specific location (Advanced).  Click Next
6. Select Search for the best driver in these locations.
    Select Include this location in the search:
    Browse to "C:\Documents and Settings\<windows user>\Desktop\arduino-0022\arduino-0022\drivers\FTDI USB Drivers"
    Click Next

I received window titled "Cannot Install this Hardware" - The hardware was not installed because the wizard cannot find the necessary software.

7.  Clicked Finish

I received "Add Hardware Wizard" window stating "This wizard is searching for hardware that has been connected to your computer recently but has not yet been installed."

I received another dialog window titled "Files Needed".  Stating "The file 'atapi.sys' on Windows XP Home Edition Service Pack 3 CD is needed"

I received the above error message previously, but also received 'usbser.sys' needed.  I found the hotfix, but tells me my current SP3 is more recent.

8.  Click Cancel since I don't know where atapi.sys might be in the file system.

9.  Bang head against desk furiously.

10.  Repeat

Someone Please Help!!!!!


Have to add.....   step 1 continues...  right clicking Other Devices > Arduino Uno, then Driver > Uninstall AND IDE ATA/ATAPI controllers > IDE Channel > Drivers > Uninstall


The Uno does not need FTDI drivers as it does not have the FTDI chip.  Forget about ATAPI, that's for ATA disk controllers.

I'm not a Windows expert, suggest you uninstall, reinstall the Arduino software and go through the checklists.
[ I will NOT respond to personal messages, I WILL delete them, use the forum please ]


Thanks Mark.  However I did right click Arduino and the IDE icons in Device Manager, click properties > drivers > uninstall.  And it uninstalled both (i didn't yet try a restart at this point)

When I try the next time, I completely remove the FTDI folder from the arduino directories, just to make sure windows doesn't pick from that sub dir.  I point to the /drivers dir and still no luck!!! 

I have had this for over a month and still have not been able to load a sketch ;-<


I'm going to try this on Ubuntu

Go Up