Go Down

Topic: HC12 Wireless Transceiver mdules will not configure (Read 294 times) previous topic - next topic


 >:(  I have three brand new HC12 modules that will not configure ... nor can I read their present configuration as shipped.  Is the quality of these modules so bad that so many of them are defective?  Am I alone or have others received HC12 modules that are unresponsive upon arrival?
 Are there any hacks/jolts/fixes that can revive a dead HC12?
 Any assistance would be greatly appreciated.


How are you trying to configure them?
The modules default to 9600, and any AT commands have to be sent at full speed with no gaps between the characters, so simply typing commands into them wont work.


I have tried with an UNO sketch in the Arduino terminal ... I have tried using an FTDI to USB and  Coolterm (a Windows terminal utility) and I have tried using the HC12 configuration utility. I am aware of the commands having to be sent (not typing) and the default 9600 bps. 
In a nutshell I have tried everything.  I am just surprised that I have received so many defective? modules and wondered if others have experienced the same or if anyone knew of a way to shock them into a functioning state.

Go Up