Go Down

Topic: Please upgrade your Yún - latest is 1.5.3 (Read 37320 times) previous topic - next topic

Angelo9999

Hello everyone,

 OpenWrt-Yun 1.5.3 is now available. You can download it from http://arduino.cc/en/Main/Software#toc8

This release includes the following changes and fixes:

OpenWrt-Yun (Linux side)
 
  • yun-gcc now includes many header files. Checkout @noblepepper blog for some instructions http://noblepepper.com/wp/blog/2014/10/22/gcc-g-on-an-arduino-yun/
  • See https://github.com/arduino/openwrt-packages-yun/issues/18
  • nodejs: bleno version bump
  • nodejs: new native module sqlite3. See https://github.com/arduino/openwrt-packages-yun/issues/20
  • nodejs: wrapper script now works well even with swap partitions (it was working with swap files only)
  • nodejs: version bump to 0.10.33

Web Panel

  • fixed wrong timezone selection on advanced settings. See https://github.com/arduino/openwrt-yun/issues/29

You can find the complete list of changes at https://github.com/arduino/openwrt-yun/blob/master/ChangeLog
https://github.com/sngl


PCWorxLA

The link is broken. :smiley-sad:
Well, it would really help to understand what you are talking about if you would be a bit more specific about which link is supposed to be broken.

If you refer to the GitHub link in Angelo's post, right before yours, well, that is working just fine for me...

Ralf

JustGreg

How does one determine which version of OpenWRT is on the YUN board?   For example, using SSH and uname -a command, I get "Linux GregYun 3.8.3 #8 Mon Aug 19 16:22:39 CEST 2013 mips GNU/Linux"   The uname command is supposed to provided the information, but, there seems nothing to relate to version 1.5.3.   I am asking this because I am having a problem with the IDE seeing the Yun board.  Both the wifi SSH and LuCI web server work great.   If the system firmware upgrade helps, then I am will do it.  But, I need to know whether I have the latest or not.

ShapeShifter

How does one determine which version of OpenWRT is on the YUN board?
From a previous discussion on the topic:

If you've just bought a Yun, it's likely you're running the old linino image or OpenWrt-Yun 1.0
To get a more precise answer, log in via ssh or yunserialterminal, then type command
Code: [Select]

cat /etc/arduino/openwrt-yun-release

If files does not exists, then you running Linino. If it exists, it will print a date: compare it from the list of date in the changelog.

JustGreg

#5
Dec 06, 2014, 04:53 pm Last Edit: Dec 06, 2014, 05:37 pm by JustGreg
Thank you, Shape Shifter for the help.  My board has Linino and not the latest OpenWRT.  Off to the upgrade instructions page. 

I did the upgrade. No luck with the connection problem.  But, I did learn something.  With uname -a command and ssh, the date listed is the released date.  In this case, 14 Nov. 2014 is the same as that in cat /etc/arduino/openwrt-yun-release

I hope this helps someone.

fmatray

Hello,
There is an issue when updating the arduino YUN using opkg.
The arduino disappear from IDE tools menu (up to date 1.5.8 ).
Avahi daemon can't open arduino.service.


Code: [Select]
root@pollux:/etc/init.d# avahi-daemon --debug
Found user 'nobody' (UID 65534) and group 'nogroup' (GID 65534).
Successfully dropped root privileges.
avahi-daemon 0.6.31 starting up.
[...]
Loading service file /etc/avahi/services/arduino.service.
[b]open("/etc/avahi/services/arduino.service", O_RDONLY): Permission denied[/b]
Failed to load service group file /etc/avahi/services/arduino.service, ignoring.


The problem is right of /etc/avahi/services/arduino.service (600). it should be 644.

Code: [Select]
root@pollux:/etc/init.d# chmod 644 /etc/avahi/services/arduino.service
root@pollux:/etc/init.d# avahi-daemon --debug
Found user 'nobody' (UID 65534) and group 'nogroup' (GID 65534).
Successfully dropped root privileges.
avahi-daemon 0.6.31 starting up.
[...]
[b]Loading service file /etc/avahi/services/arduino.service.[/b]
Loading service file /etc/avahi/services/ssh.service.
Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.0.5.


Now, it works :-)
Best regards,
Frédéric

mart256

Just a brief report:

Upgraded to 1.5.3 using this tutorial and using the web panel method.

I noticed that the Yun image must be mounted in /mnt/sda1. On my first attempt I mounted it to /mnt/elsewhere and the webpanel didn't show up the "reset" option.

Besides that, the process went smooth and I haven't had any trouble, I just had to re-install some drivers for my webcam but that went ok too.

And my Yun does appear on Arduino IDE, I didn't have that problem.

ponley

Is there a way to get an image using the Backfire version of OpenWRT?

I got the Arduino Yun with the intention of setting it up as a router but the Attitude Adjustment version of OpenWRT has very broken IPv6 tunneling tools. I have used the Backfire version of OpenWRT for years very successfully with IPv6 tunneling but the documentation on the Yun did not specifically state which version of OpenWRT was included.

Angelo9999

Hello,

as you said the Arduino Yun OpenWrt version is the Attitude Adjustment.

This is the only version available for the Arduino Yun. Getting a vanilla OpenWrt image working is possible (and not supported)  but you won't have all the Yun customization and features.
https://github.com/sngl

iamadog3333

I can open the link below:
http://arduino.cc/en/Main/Software#toc8

But the image resouse is not avaiable and can not be downloaded.


Angelo9999

I just tried it and it works, can you try again?
https://github.com/sngl

iamadog3333

#12
Jan 22, 2015, 09:51 am Last Edit: Jan 22, 2015, 10:42 am by iamadog3333
Dear Angelo9999,
May be the internet is blocked by the "Wall".
I am locating at Beijing.

Thank you anyway!

Angelo9999

If you can't download it, send me a pm with your contact and I will send you the file.
https://github.com/sngl

heggood

Are there any special considerations for a yun that has been expanded onto an SD card?
Will any of the files on the SD card be affected?  After upgrade, will it still use the overlay?
It's much easier to make working code elegant than make elegant code work!

Go Up