Go Down

Topic: Please upgrade your Yún - latest is 1.5.3 (Read 33536 times) previous topic - next topic

Angelo9999

root@Arduino545:~# run-sysupgrade /mt/sdal/openwrt-ar71xx-generic-yun-16M-squash
fs-sysupgrade.bin
cp: can't stat '/mt/sdal/openwrt-ar71xx-generic-yun-16M-squashfs-sysupgrade.bin': No such file or directory
Please check syntax and typos. It is probably mnt instead of mt and sda1 instad of sdal.

https://github.com/sngl

cmoze1

Please check syntax and typos. It is probably mnt instead of mt and sda1 instad of sdal.


Thanks for catching my typos.  I tried it again, being very careful with the typing and still getting the same result.  Here's my latest attempt:

root@Arduino545:~# run-sysupgrade /mnt/sda1/openwrt-ar71xx-generic-yun-16M-squas
hfs-sysupgrade.bin
cp: can't stat '/mnt/sda1/openwrt-ar71xx-generic-yun-16M-squashfs-sysupgrade.bin': No such file or directory

I don't know why the tilde and hashmark (~#) is coming after my Arduino's name in the Terminal program or how to get rid of them. I noticed nobody else's on this forum seems to have those marks. Could that be the problem? The file is located on the root directory of my SD card.

cmoze1

Figured it out and I feel a little dumb. I was inserting the SD card with the Yun powered up. The card apparently needs to be inserted with Yun powered off, then once the card is in, power up the Yun.  Duh.

Baptistou_15

Hello,
I have just bought an arduino Yun. The WiFi worked correctly and was accessible(approachable) by IDE 1.5.8 and to the address 192.168.240.1.
As you advise(recommend) it, I made the update of Open-WRT with the file Sysupgradelmage_v1.5.3.zip.
Since more access to the WiFi by the interface IDE. I tried a reset by pressing on the WiFi reset during 2 minutes but unsuccessfully. I looked for a simple solution on Web, also without succèsM.
Thank you for bringing me your help(assistant).

tomb18

Here is a question for the Moderators.  Can I get my arduino.org version of the YUN to work with the arduino.cc code?
There seems to be zero support on the arduino.org site.

jessemonroy650

Here is a question for the Moderators.  Can I get my arduino.org version of the YUN to work with the arduino.cc code?
There seems to be zero support on the arduino.org site.

@tomb18,
that's good and dis-hearting to hear. All Arduino developers would like to see other developers succeed. However, this silly argument (which as you know is in court), is not helping.

Perhaps we can get arduino.org to make the change, or at least meet half way.

FWIW: this question would be better on it's own thread -- so it more visible to management. You might want to consider that. I'm sure people will add comments.

Jesse

blackt1ger

Could someone help me out with version numbers please.  I've pulled out my old Yun 1.0 Shield and want to get it all updated.

luci shows me firmware Dragino-v2 common-2.0.7, Kernel 3.3.8.

/etc/openwrt_version is '1'.

-------------

So, what and how to get everything up to snuff.  I have no idea how to relate any of these numbers to 1.5.3 .... :)  And isn't openwrt in the 12.0-14.0 range?  Is the firmware part of the Linux kernel?  How does that get updated?


-------------
Currently, it appears that my Bridge is not working.  It wasn't even show as an installed package "cpu-mcu-bridge".  I installed it and rebooted, still no luck.  Should the bridge also get started from a start up script?



jessemonroy650

Could someone help me out with version numbers please.  I've pulled out my old Yun 1.0 Shield and want to get it all updated.

::::SNIP::::

@blackt1ger,
your question is off subject. Please start a new thread. This thread is for upgrading. Your issue is about the "Shield". This thread is NOT about the "Shield".
Jesse

ShapeShifter

@blackt1ger,
your question is off subject. Please start a new thread. This thread is for upgrading. Your issue is about the "Shield". This thread is NOT about the "Shield".
Jesse
I will second Jesse on this one: you are talking a out a product from Dragino that runs their own software build: it is not an arduino.cc product and is not running the software mentioned in this thread.

blackt1ger

Okay, well, obviously I am very terribly confused and I am so sorry that I offended the Yun people with my  question about a SHEILD..


It was my understanding that the Yun and an Arduino with a Yun shield were the same.

But thank you for sharply pointing out that I have absolutely no business being here or asking questions.

However --- I HAVE BEEN TRYING TO UPGRADE TO THE LATESET 1.5.3 -----   

It must've been the topic that threw me.   I'll go somewhere else, where I can get knowledgeable help.


ShapeShifter

It was my understanding that the Yun and an Arduino with a Yun shield were the same.
They may be functionally similar, but they are not identical. There may be subtle differences between them and the software that runs on the Linux processor.

Your specific question was about figuring out version numbers - since you are looking at a different product with software distributed by a different company, any version numbers relating to the software in this thread will not apply to the version of the software on your device, and vice versa.

The software and procedure being discussed in this thread may or may not work on your shield, but that should be discussed in a different thread, not on this one.

Quote
But thank you for sharply pointing out that I have absolutely no business being here or asking questions.
Nobody has said that. Both Jesse and I said you should start a new thread about this topic - nobody has said you should go away or look for a different forum. If someone wanted you to go away, they would've said that - an invitation to start a new discussion is not a request to leave. You are welcome at this forum, and if you start a topic about how to relate the version numbers between the shield and the Yun, (and I assume you also want to know if this software will work on your shield) we will be happy to discuss it with you in your thread.

AntonySerio

I purchased a new Yun yesterday afternoon. It boots, it's on the network, I can get to the configure page and I can SSH into the board's filesystem. I have the latest image on an SD card, but my Yun is unable to see it. I reformatted the card as Fat32 using Apple's disk utility, to no avail. The /mnt directory on the Yun is empty, and the only directories that I see in my /dev directory are bsg, bus, input, pts, and shm. None of them lead anywhere. The SD card is a few years old, so it COULD be flaky, but my mac can read it just fine. Any assistance would be appreciated.

mart256

Write dmesg on the console to check if a new device appears when you plug the sd.

AntonySerio

I ran dmesg -c to clear the buffer, pulled the card, re-inserted the card, and ran dmesg again. There were no new messages.

AntonySerio

After reseating the card several times, suddenly my Yun is able to read the card. Proceeding with upgrade. Thanks for the help...

Go Up