Go Down

Topic: Arduino Yun - Unable to Connect to WPA2-Enterprise (Read 691 times) previous topic - next topic

GyldenGlor

Hey everyone!

I've been working my ass off for the past few weeks struggling to get this damn thing to connect to the wifi at NYU. I've done a whole multitude of things, including the solution from here, and I've also followed multiple other sources online, including from OpenWRT forums and linux forums, including one method by using the Luci advanced configuration panel to set up the wifi.

Regardless of what I try, I always get the following:

Quote
deauthenticating from (address of router) by local choice (Reason: 3=DEAUTH_LEAVING)
This occurs pretty much immediately after it associates with a router. I've registered the Yun with the university, and I've used all permutations of settings I could think of, and I updated OpenWRT.

Sometimes, I never get to associating with a router - it times out on each of them. (I leave the hardware address blank in Luci so it can find the nearest router, since I don't know the address of said router).

I'm seriously at the end of my rope here, I don't know what else to try - I've easily spent over forty hours on this thing.

sonnyyu

#1
May 02, 2017, 03:36 pm Last Edit: May 02, 2017, 03:41 pm by sonnyyu
Few things could help you:

1. Connect Yun while wire network (ethernet), and ssh to console.

2. Use Linux laptop ( or live CD to boot ) setup  WIFI


3. Install CA into Yun (in case trust server is public signed).

Code: [Select]
opkg update
opkg install ca-certificates


4. Copy CA certificate file and config setting from Linux box.

Code: [Select]

eap_type (none) Defines the EAP protocol to use, possible values are tls for EAP-TLS and peap or ttls for EAP-PEAP
auth MSCHAPV2 "auth=PAP"/PAP/MSCHAPV2 - Defines the phase 2 (inner) authentication method to use, only applicable if eap_type is peap or ttls
identity (none) EAP identity to send during authentication
password (none) Password to send during EAP authentication
ca_cert (none) Specifies the path the CA certificate used for authentication


https://wiki.openwrt.org/doc/uci/wireless









GyldenGlor

Few things could help you:

1. Connect Yun while wire network (ethernet), and ssh to console.

2. Use Linux laptop ( or live CD to boot ) setup  WIFI


3. Install CA into Yun (in case trust server is public signed).

Code: [Select]
opkg update
opkg install ca-certificates


4. Copy CA certificate file and config setting from Linux box.

Code: [Select]

eap_type (none) Defines the EAP protocol to use, possible values are tls for EAP-TLS and peap or ttls for EAP-PEAP
auth MSCHAPV2 "auth=PAP"/PAP/MSCHAPV2 - Defines the phase 2 (inner) authentication method to use, only applicable if eap_type is peap or ttls
identity (none) EAP identity to send during authentication
password (none) Password to send during EAP authentication
ca_cert (none) Specifies the path the CA certificate used for authentication


https://wiki.openwrt.org/doc/uci/wireless









Thanks for the fast reply, but I'm afraid that that still hasn't done it - the settings the Linux box gave me were the exact same as the settings I've been using on my Arduino.

Just to be sure, I've done it several times - each time gave the same results, and the Yun will still deauthenticate regardless of its settings.

It connects to hotspots and non-WPA2 Enterprise connections just fine, but no matter what I try it still deauthenticates from the connection.

sonnyyu

#3
May 03, 2017, 07:45 pm Last Edit: May 03, 2017, 07:48 pm by sonnyyu
Upgrade kernel ?  The openwrt forum some one report after upgrade to LEDE  WPA2-Enterprise suddenly worked.

How to find out firmware version of Yun, Yun Shield, Dragino Shield.









GyldenGlor

Upgrade kernel ?  The openwrt forum some one report after upgrade to LEDE  WPA2-Enterprise suddenly worked.

How to find out firmware version of Yun, Yun Shield, Dragino Shield.









When I use PuTTY and the serial sketch to determine the kernel version, the Yun informs me that it is "Linux Arduino 3.3.8"

sonnyyu

3.3.8      12.09  - September,2012




5 years old pet  is approximately 36 human years old.
   
How old is your computer in human years?


Your Yun is approximately 86 human years old.












GyldenGlor

I may have messed up, but I hope I didn't.

I flashed my Yun to LEDE 17.10, based on what you said about LEDE fixing WPA2-Enterprise issues.


However, now, when I connect to the Yun's WiFi, the Luci homepage is not available, and that it "took too long for the webpage to respond". It WILL however, before showing the error page, show the initial all-blue page with text in the top-left corner instructing me to wait a moment.

Also, a little more distressingly, now that I've updated to LEDE, the USB LED does not turn on when connected to the computer. Instead, the WAN light turns solid when connected by USB.


Any suggestions, or did I effectively brick my Yun?

GyldenGlor

3.3.8      12.09  - September,2012




5 years old pet  is approximately 36 human years old.
   
How old is your computer in human years?


Your Yun is approximately 86 human years old.












I don't know if this is a double post or not, I was told it didn't work, if it is, sorry.

So I got the Yun to run on Lede 17.01, and it connected to WPA2-Enterprise.

Unfortunately, the white USB light now does not turn on, and I can only run things like Curl through the command line in PuTTY while running the Serial Terminal sketch. On any other sketch when I need to use Curl, it will hang on Bridge.begin().

Any suggestions?

sonnyyu

#8
May 04, 2017, 11:52 pm Last Edit: May 04, 2017, 11:55 pm by sonnyyu
The white USB light now does not turn on.
Report it to LEDE forum, it is AR9331 GIOP map issue, need change source code.


and I can only run things like Curl through the command line in Putty while running the Serial Terminal sketch. On any other sketch when I need to use Curl, it will hang on Bridge.begin().
Putty SSH to the Yun, test Curl?






GyldenGlor

Report it to LEDE forum, it is AR9331 GIOP map issue, need change source code.


Putty SSH to the Yun, test Curl?






I'll make sure to report it to the forum.

I've done only a serial connection to the yun to use Curl, but whenever I attempt anything that requires an internet connection on the Yun's serial terminal, it will fail unless it's connected and the thing I'm trying to use is installed - though I may be wrong about that.

Thanks again!

sonnyyu


GyldenGlor

SSH to the Yun:

https://www.arduino.cc/en/Tutorial/LinuxCLI


Test Curl:

Code: [Select]
curl www.example.com


Write Ash(Bash)/PHP/Python Curl wrapper code:

http://www.ibuyopenwrt.com/index.php/8-yun-compatible/56-upload-image-to-firebase-base64

Use Process Class complete function:

http://www.ibuyopenwrt.com/index.php/bridge-library







So, even though the arduino says it has an IP address when I use PuTTY via serial connection, when I power it without connecting it to my PC, I don't see it available on the arduino software, even though I'm on the same network as the Arduino (supposedly).

I noticed that there's actually a version of LEDE a bit newer than my own (a service update), and that there are two options for the Yun: one that says "16M" and one that says "8M".

So, should I just flash on the new version of Lede, and see how that works? And which option should I choose?

sonnyyu

#12
May 08, 2017, 07:45 pm Last Edit: May 08, 2017, 07:46 pm by sonnyyu
If I were you, I will go ahead to get one router connected to WPA2-Enterprise then connect PC and Yun via ethernet cable direct.

Make sure select router which supports WPA2-Enterprise.


mossad丶

Hey everyone!

I've been working my ass off for the past few weeks struggling to get this damn thing to connect to the wifi at NYU. I've done a whole multitude of things, including the solution from here, and I've also followed multiple other sources online, including from OpenWRT forums and linux forums, including one method by using the Luci advanced configuration panel to set up the wifi.

Regardless of what I try, I always get the following:

This occurs pretty much immediately after it associates with a router. I've registered the Yun with the university, and I've used all permutations of settings I could think of, and I updated OpenWRT.

Sometimes, I never get to associating with a router - it times out on each of them. (I leave the hardware address blank in Luci so it can find the nearest router, since I don't know the address of said router).

I'm seriously at the end of my rope here, I don't know what else to try - I've easily spent over forty hours on this thing.
Hi,GyldenGlor

      I meet the same issue , the company I worked in uses the WIFI encrypted with WPA2-Enterprise , after I replaced the wpad-mini to wpad on the LininoOS, I config my Yun to connect the conpany's WIFI , but it didn't work , Once it authented and associated then it will print "deauthenicating from ........."  message in the console.
      I struggled with the problem until I find that the reason is time. When I click the "sync time with brower" button in Luci , then I can config it to connect to the damn WIFI . The Yun doesn't have RTC , so when it lose power , the Yun 's time will be reset to defaults . Even my Yun connected to the WIFI , when I replug the power plug , the "deauthenicating from ........." message will appear again...
      My english is not very well , but I hope it may help you .


sonnyyu

Hi,GyldenGlor

      I meet the same issue , the company I worked in uses the WIFI encrypted with WPA2-Enterprise , after I replaced the wpad-mini to wpad on the LininoOS, I config my Yun to connect the conpany's WIFI , but it didn't work , Once it authented and associated then it will print "deauthenicating from ........."  message in the console.
      I struggled with the problem until I find that the reason is time. When I click the "sync time with brower" button in Luci , then I can config it to connect to the damn WIFI . The Yun doesn't have RTC , so when it lose power , the Yun 's time will be reset to defaults . Even my Yun connected to the WIFI , when I replug the power plug , the "deauthenicating from ........." message will appear again...
      My english is not very well , but I hope it may help you .


Manual setup default date/time on Yun

Put this into startup init:

Code: [Select]
date -s  hh:mm[:ss] or [YYYY.]MM.DD-hh:mm[:ss] or YYYY-MM-DD hh:mm[:ss] or [[[[[YY]YY]MM]DD]hh]mm[.ss]









Go Up