The HATRED for String objects - "To String, or not to String"

A fairly simple fix in fact is to have a naming convention for class variables, eg.

int m_myVariable;   // m_ = member; or:
int myVariable_;    // using trailing underscore on class variables