Go Down

Topic: Arduino gibt bei analog/digitalRead nur '0' aus (Read 1 time) previous topic - next topic

HotSystems

Das mit den 5V vom Arduino habe ich wieder verworfen. Aber man könnte doch die 5V von dem Netzteil nehmen, an dem der Arduino angeschlossen ist, und die vorn an den Hub anschließen? Was spräche dagegen?
Das hatte ich ja auch schon geschrieben.
Einen USB-Hub mit externer Versorgung und daran die Arduinos, ohne eigene Versorgung.
So könnte es gehen.
Das Netzteil sollte aber auch min. 2A liefern.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Techniker89

#16
Jan 13, 2018, 04:48 pm Last Edit: Jan 13, 2018, 04:49 pm by Techniker89
Quote
Einen USB-Hub mit externer Versorgung
Ich dachte du meinst einen, der direkt so hergestellt wurde.

Edit: 2A für einen Arduino (mit sehr wenig Last) und einen USB-Hub? Ist das nicht ein bisschen viel?

Tommy56

Ein USB-Hub sollte an jeden Ausgang mindestens 500 mA anbieten können - gleichzeitig.

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

Techniker89

Ein USB-Hub sollte an jeden Ausgang mindestens 500 mA anbieten können - gleichzeitig.
Mag sein, aber in meinem Fall hängt ja keine direkte Last am USB-Port. Die eigentliche Spannungsversorgung bilden ja die Netzteile der Arduinos.

HotSystems

Ich dachte du meinst einen, der direkt so hergestellt wurde.

Edit: 2A für einen Arduino (mit sehr wenig Last) und einen USB-Hub? Ist das nicht ein bisschen viel?
Ja, einen USB-Hub der mit einem externen Anschluss hergestellt ist.

Und nein, 2 A ist nicht zu viel. Lieber etwas mehr, als zu wenig.
Du brauchst Reserven und schaden können die nicht, auch nichts beschädigen, wenn du alles richtig machst.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

HotSystems

Mag sein, aber in meinem Fall hängt ja keine direkte Last am USB-Port. Die eigentliche Spannungsversorgung bilden ja die Netzteile der Arduinos.
Ääähhh du wolltest doch die Arduino aus dem Hub versorgen.
Jetzt weis ich nichts mehr.....
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Techniker89

Quote
Ja, einen USB-Hub der mit einem externen Anschluss hergestellt ist.
Aber ich denke, wenn man die 5V des Netzteils vor den Hub schaltet, kommt es auf dasselbe raus (vorausgesetzt das Netzteil bietet die passende Stromstärke). Ich möchte mir nämlich nicht noch was kaufen müssen.

Quote
Ääähhh du wolltest doch die Arduino aus dem Hub versorgen.
Jetzt weis ich nichts mehr.....
Wann hab ich das gesagt? Schau doch mal in den Schaltplan. Da steht doch alles.

Tommy56

Dieses Mal gebe ich auf. Viel Spaß noch.

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

HotSystems

Aber ich denke, wenn man die 5V des Netzteils vor den Hub schaltet, kommt es auf dasselbe raus (vorausgesetzt das Netzteil bietet die passende Stromstärke). Ich möchte mir nämlich nicht noch was kaufen müssen.

Wann hab ich das gesagt? Schau doch mal in den Schaltplan. Da steht doch alles.
Ich hatte es in Post #15 so geschrieben.

Und deine Schaltung ist für mich keine Schaltung, die verstehe ich nicht.
Sorry aber das ist kein Schaltbild.

Und nochmals, du brauchst einen Hub, der einen externen Spannungsanschluß hat.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

HotSystems

Dieses Mal gebe ich auf. Viel Spaß noch.

Gruß Tommy
Tommy, du hast Recht, hier kann man verzweifeln.
Aber ich versuche es weiter. ;)
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Techniker89

Tut mir ja leid, wenn es hier zu Verwirrungen kommt. Aber mein Gedanke ist es, es so zu machen wie in dem Schaltplan. Das heißt: Spannungsversorgung der Arduinos über Netzteil, Daten kommen vom Raspberry über USB - bis hier weitestgehend 'Standardfall'.

Damit der Raspberry nicht überlastet wird, kappe ich die 5V-Leitung des USB zwischen ihm und dem Hub. Damit der Hub wiederum aber noch mit Spannung versorgt wird, schließe ich an der Trennstelle der 5V-Leitung auf Seiten des Hubs die 5V aus einem Netzteil an.

Das wäre ja eigentlich auch das Funktionsprinzip eines fertigen Hubs mit Netzteil, oder nicht?
Leider hat mir bis jetzt noch niemand gesagt, ob das so funktionieren würde und warum (nicht).

Wenn es nur am Schaltplan liegt, dass meine Gedanken so unverständlich erscheinen, kann ich auch einen neuen machen.

HotSystems

Verwirrung nur, weil du nicht konkret beschrieben hast, wie du deine Spannungsversorgung anschließen möchtest.
Die externe Spannung eines USB-Hubs wird immer über eine Netzteilbuchse angeschlossen, niemals über das USB-Kabel.
Da das vermutlich so noch keiner gemacht hat (es ist Pfusch) wird dir vermutlich auch keiner bestätigen, ob es funktioniert.
Es könnte funktionieren, ist aber unsicher.
Damit hast du dann aber auf jedenfall wieder "doppelte" Spannung auf den Arduinos. Doppelt im Sinne von einmal aus dem USB-Hub und einmal durch dein Netzteil. Und das ist wiederum auch nicht zu empfehlen.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Techniker89

Es könnte funktionieren, ist aber unsicher.
Damit hast du dann aber auf jedenfall wieder "doppelte" Spannung auf den Arduinos. Doppelt im Sinne von einmal aus dem USB-Hub und einmal durch dein Netzteil. Und das ist wiederum auch nicht zu empfehlen.
Macht Sinn, dann werde ich mir wohl doch noch sowas bestellen müssen.

ElEspanol

Brauchen die Arduinos unbedingt ein eigenes Netzteil? Weil du kannst schon die 5V vom Netzteil in die aufgetrennte Versorgungsleitung einspeisen. Dann bekommen die Arduinos über usb Saft. Aber sollte eben keine weitere Versorgung über den 5V Pin mehr erfolgen.

Techniker89

Brauchen die Arduinos unbedingt ein eigenes Netzteil? Weil du kannst schon die 5V vom Netzteil in die aufgetrennte Versorgungsleitung einspeisen. Dann bekommen die Arduinos über usb Saft. Aber sollte eben keine weitere Versorgung über den 5V Pin mehr erfolgen.
Das wäre natürlich am besten. Ich habe im Anhang mal noch einen Schaltplan hochgeladen. Ich bin mir dann nur nicht sicher, ob ich das eingezeichnete Netzteil nehmen sollte, oder doch lieber das andere mit 4,95V aber nur 1A.

Go Up