Go Down

Topic: Arduino IDE erkennt plötzlich Nano nicht mehr (Read 149 times) previous topic - next topic

arduino-wasser

Hallo zusammen,
habe nun einige Zeit nicht mit der Arduino IDE gemacht, wollte jedoch nun wieder etwas basteln. Jedoch erkennt scheinbar die IDE nun das Arduino Nano nicht mehr.

Hab den Nano und den richtigen COM Port ausgewählt, läuft jedoch immer auf den selber error raus aus dem ich nicht so recht schlau werde.

Quote
Warning: Board arduino:avr:?menu doesn't define a 'build.board' preference. Auto-set to: AVR_?MENU
avr-g++: error: missing device or architecture after '-mmcu='

exit status 1
Fehler beim Kompilieren für das Board Arduino Nano.
Ich habe nicht in irgendeiner der Config Datein geändert. Würde mich aber freuen wenn mir jemand erklärt woran es dabei hackt, sieht für mich nämlich aus als würde es an irgendeiner Config Einstellung hacken....

danke schonmal für eure Geduld

HotSystems

Das sieht nach einem Fehler in der IDE aus. Du solltest diese neu installieren.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

BluetoothHamster

#2
Jan 13, 2018, 11:40 pm Last Edit: Jan 13, 2018, 11:50 pm by BluetoothHamster
Hallo arduino-wasser,

was für eine Arduino Version und welches Betriebssytem setzt du ein ?

Per Google habe ich folgendes gefunden:
nur ein Link









______
Wasser ist in seiner reinsten Form ein Nichtleiter (zumindest ein Isolator, weil es keine Nichtleiter gibt), nur kommt das so selten vor.

arduino-wasser

Also habe IDE 1.8.3 und nutze Win10.

Ich habe gerade gemerkt das sowohl im Programme(x86) ein Arduino Pfad als auch unter dem lokalen Benutzer unter "BenutzernameWindows/AppData/Local/Arduino15/..."

kann es sein das da irgendwas sich beißt?

HotSystems

Also habe IDE 1.8.3 und nutze Win10.

Ich habe gerade gemerkt das sowohl im Programme(x86) ein Arduino Pfad als auch unter dem lokalen Benutzer unter "BenutzernameWindows/AppData/Local/Arduino15/..."

kann es sein das da irgendwas sich beißt?
Das sieht soweit ok aus.
Du solltest eine neue Installation machen, das hilft oft bei Fehlern.


Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

BluetoothHamster

Deinstalliere alle Arduino-Versionen und installiere danach nur eine Version.
Oder installiere die anderen Versionen in ein eigenes festgelegtes Verzeichnis.

Lösche auch alle temporären Abhängigkeiten (incl. Registry) die mit Arduino zu tun haben.

Go Up