Go Down

Topic: how to make my stepper motor start...??? plz help (Read 209 times) previous topic - next topic

Ashkill94

Hey guys i am new to all this circut connections plz help
 having trouble to make my stepper motor work...

1- i am using arduino mega kit
2- stepper motor driver model no. - TB 6560

i want to know what connection do i have to make with driver to make it work my coding is in attachments
PLZ help iff you can...


Thanks...!!!!

groundFungus

#1
Nov 14, 2017, 01:56 pm Last Edit: Nov 14, 2017, 02:08 pm by groundFungus
There seem to be a number of boards that use the TB6560.  It might be useful to know which one that you have.  A data sheet or link to one would be most useful.   Instead of trying to make the stepper work with that long code, maybe write a small sketch to test the motor(s) and driver by themselves. 

Robin2

Hey guys i am new to all this circut connections plz help
 having trouble to make my stepper motor work...
I have had a quick look at your program.

To learn how to make your stepper motors move start with the simplest program possible. Have a look at this Simple Stepper Code.


As a separate point there is a huge amount of stuff in your program - about 200 lines of code in loop() dealing with (I think) a camera, stepper motors, switches and LEDs. It will be much easier to develop, test and debug your program if you divide it up into small single-purpose functions. Have a look at Planning and Implementing a Program

...R
Stepper Motor Basics

Two or three hours spent thinking and reading documentation solves most programming problems.

TomGeorge

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

A link to specs/data of your driver will help us to help  you.

Thanks.. Tom.. :)
Everything runs on smoke, let the smoke out, it stops running....

Ashkill94

#4
Nov 15, 2017, 05:01 am Last Edit: Nov 15, 2017, 05:16 am by Ashkill94
There seem to be a number of boards that use the TB6560.  It might be useful to know which one that you have.  A data sheet or link to one would be most useful.   Instead of trying to make the stepper work with that long code, maybe write a small sketch to test the motor(s) and driver by themselves.  
link for stepper motor driver i am using

Ashkill94

I have had a quick look at your program.

To learn how to make your stepper motors move start with the simplest program possible. Have a look at this Simple Stepper Code.


As a separate point there is a huge amount of stuff in your program - about 200 lines of code in loop() dealing with (I think) a camera, stepper motors, switches and LEDs. It will be much easier to develop, test and debug your program if you divide it up into small single-purpose functions. Have a look at Planning and Implementing a Program

...R
Stepper Motor Basics


thank you for that planing link i didnt knew that i can write short codes and make them work as sketch.... TY
yeah i am trying to build remote control car robo.... other all functions are working perfectly i.e LED, cameras , and DC motors of actual car... and stepper motor is mounted on top of robo with totally different agenda...

Ashkill94

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

A link to specs/data of your driver will help us to help  you.

Thanks.. Tom.. :)
yeah i tried that but the site wont let me... cause the code is too long to post here.... so i attached it in attachments..

TomGeorge

#7
Nov 15, 2017, 08:13 am Last Edit: Nov 15, 2017, 08:18 am by TomGeorge
Hi,
I have looked at your code.

If you do not know how to connect the stepper driver, why have you written so much code?

You need to develop your code in stages.

First code should be a simple code to make the stepper move, NOT the complex code you have written.

Developing your code in stages, making sure each stage works before advancing to the next.

Please take the advice given above and just write some code to get the stepper moving.

Thanks.. Tom... :)
PS. A quick look for a manual only gave me the 3 and 5axis boards using the same driver, you may have to look at one of them to get basic connections.
Everything runs on smoke, let the smoke out, it stops running....

Ashkill94

Hi,
I have looked at your code.

If you do not know how to connect the stepper driver, why have you written so much code?

You need to develop your code in stages.

First code should be a simple code to make the stepper move, NOT the complex code you have written.

Developing your code in stages, making sure each stage works before advancing to the next.

Please take the advice given above and just write some code to get the stepper moving.

Thanks.. Tom... :)
PS. A quick look for a manual only gave me the 3 and 5axis boards using the same driver, you may have to look at one of them to get basic connections.
i worte it in stages last step was of stepper motor.... everything else works fine and i did connections which i knew but my motor just does humming sound and shakes.. i tried replacing motor and driver both but result is same...:(

Robin2

i worte it in stages last step was of stepper motor.... everything else works fine and i did connections which i knew but my motor just does humming sound and shakes.. i tried replacing motor and driver both but result is same...:(
I'm pretty sure @TomGeorge meant "separate stages" rather than adding untested stepper code into an already working program.

...R
Two or three hours spent thinking and reading documentation solves most programming problems.

TomGeorge

Hi,
Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

And a simple code JUST to drive your stepper, leave the rest out.

Thanks..  Tom... :)
Everything runs on smoke, let the smoke out, it stops running....

Ashkill94

ty every one( TOM GORGE & ROBINE2) my problem is resolved turns out i didn't club all the negatives of stepper driver... its working good now... THANK YOU for taking time and responding me

Go Up